dmutallapova
19.09.2021 04:39

Написать программу, 25 в офисе, где работает программист петр, установили кондиционер нового типа. этот кондиционер отличается особой простотой в . у кондиционера есть всего лишь два параметра: желаемая температура и режим работы. кондиционер может работать в следующих четырех режимах: 1 – «freeze» — охлаждение. в этом режиме кондиционер может только уменьшать температуру. если температура в комнате и так не больше желаемой, то он выключается. 2 – «heat» — нагрев. в этом режиме кондиционер может только увеличивать температуру. если температура в комнате и так не меньше желаемой, то он выключается. 3 – «auto» — автоматический режим. в этом режиме кондиционер может как увеличивать, так и уменьшать температуру в комнате до желаемой. 4 – «fan» — вентиляция. в этом режиме кондиционер осуществляет только вентиляцию воздуха и не изменяет температуру в комнате. кондиционер достаточно мощный, поэтому при настройке на правильный режим работы он за час доводит температуру в комнате до желаемой. требуется написать программу, которая по заданной температуре в комнате t-room, установленным на кондиционере желаемой температуре t-cond и номеру режима работы определяет температуру, которая установится в комнате через час

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ЛизаПру
15.04.2020 13:48
// PascalABC.NET 3.0, сборка 1144 от 16.01.2016
begin
  var n:=ReadInteger('n=');
  var a:=ArrRandom(n,-50,50);
  Writeln('Исходный массив'); a.Println;
  var se:=a.Where(x->x mod 3=0);
  if se.Count=0 then
    Writeln('В массиве нет элементов, кратных трем')
  else begin
    var b:=se.Max;
    var i:=0;
    while a[i]<>b do Inc(i);
    if i=n-1 then Writeln('Максимальный элемент - последний')
    else begin
      Writeln('Результирующий массив');
      a[i+1]:=abs(a.Where(x->x<0).Sum); a.Println
      end
    end
end.

Тестовое решение:
n= 15
Исходный массив
-24 -38 15 -33 -40 -18 21 34 20 49 -19 29 29 38 -41
Результирующий массив
-24 -38 15 -33 -40 -18 21 213 20 49 -19 29 29 38 -41
0,0(0 оценок)
Ответ:
dvc
15.04.2020 13:48
1.  и 2. записываем в столбик в виде суммы:

1.       +  n 3 8  9  8
               2 n 7 5  m
           
              m 8 5 n  3
ясно, что основание искомой с/с > 10.  Проверим и удостоверимся, что в 11c|c  действия выполняются верно.
 11 c|c   M=6   n = 4    
ответ: основание системы   11,  m=6,    n=4

2.   m m 65 n
    +2 n 4 4 m         

       5 5 4 2 4      очевидно, что основание искомой с/с > 6. 
Проверим по действиям в 7 с/с,  при сложении в столбик,
  при m=3 и n=1
и удостоверимся, что всё верно.
ответ:    осн. с\с = 7, m=3, n=1

3. пусть основание с\с будет  X? тогда:
(4*X^2+X+5)*4 =2*X^3+2*X^2+6*X+6
    раскрываем скобки, преобразуем и получаем уравнение:
(2*X - 14)*(X^2+1) = 0  --->    X=7
ответ:7
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота