valeriya309
25.09.2021 05:44

Написать программу в Pascal ABC. Дана строка, слова в строке разделены пробелами, сколько слов в этой строке?

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:

Если считать, что количество пробелов между словами всегда равно 1, а также что нет пробелов до и после последовательности, то количество слов = количеству пробелов + 1.

Код:

program words;var    s: string;    k, i: integer;begin    WriteLn('Введите последовательность слов с пробелами:');    ReadLn(s);    k := 1;    for i := 1 to length(s) do        if s[i] = ' ' then k := k + 1;    WriteLn('Кол-во слов: ', k);end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота