kholdingmedia
29.04.2023 03:08

Кому не информатика. протестировать в паскаль и результат. чепуху не писать! ) опишите содержимое текстового файла, из которого будут вводиться данные, соответствующие описанию из предыдущего , для нескольких учеников класса (не менее 5).

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
baby2525
27.02.2022 05:56

372

Объяснение:

Запишем для каждого числа, сколькими его можно получить из предыдущих чисел. Отдельно посчитаем программы 2 -> 5, 5 -> 26. Тогда для получения ответа достаточно перемножить результаты первой и второй программ (на каждый результат первой программы приходится каждый результат второй программы).

2 -> 5:

2 — 13 — "2" — 14 — "3" + "2" — 25 — "4" — 2

5 -> 26:

5 — 16 — "5" — 17 — "6" — 18 — "7" — 19 — "8" — 110 — "9" + "5" — 211 — "10" + "6" — 312 — "11" + "7" — 413 — "12" + "8" — 514 — "13" + "9" — 615 — "14" + "10" — 816 — "15" + "11" — 1117 — "16" + "12" — 1518 — "17" + "13" — 2019 — "18" + "14" — 2620 — "19" + "15" — 3421 — "20" + "16" — 4522 — "21" + "17" — 6023 — "22" + "18" — 8024 — "23" + "19" — 10625 — "24" + "20" + "5" — 14126 — "25" + "21" — 186

2 * 186 = 372

0,0(0 оценок)
Ответ:
Dima1Tap
04.04.2023 10:26
Летающий автобус)
1. Мест в эконом-классе 120, а в бизнес-классе 40.
2. 100 процентов прибыли получим, если заполним все места. Билет в эконом-классе стоит в 2 раза меньше чем X. Получаем следующее уравнение:
40*X + 0.5*120*X = 100%, X = 1% от всей прибыли.  Значит один билет в бизнес - классе приносит один процент прибыли. А один билет в эконом-классе приносит 0.5 процента прибыли.
3. Осталось рассчитать прибыль компании учитывая непроданные билеты:
P = 100 - b - 0.5*a  и написать программу:

var a,b:integer;
begin
  repeat
    writeln('Введите количество непроданных билетов (a,b)');
    readln(a,b);
  until (a<=120) and (b<=40)and (a>=0) and (b>=0);
  writeln('Прибыль компании составит ',100-b-0.5*a,'%');
end.

 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота