merimargaryan
18.06.2021 03:59

3. составить программу, которая вычисляет сумму вклада в банке через n лет, если первоначальный взнос - м рублей, а процентная ставка - 8,5% годовых. (решать через цикл for)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
umkhaev013suleiman
28.06.2021 13:11

Можно либо циклы в общем цикле (коротко и красиво):

использовать Робот

алг

нач

нц пока снизу свободно

вниз

нц пока справа свободно

вправо

кц

нц пока снизу свободно

вниз

кц

нц пока слева свободно

влево

кц

кц

кон

То же самое ещё понятнее и короче выглядит, если малые циклы в строчку записать:

использовать Робот

алг

нач

нц пока снизу свободно

вниз

нц пока справа свободно; вправо кц

нц пока снизу свободно; вниз кц

нц пока слева свободно; влево кц

кц

кон

Либо просто несколько циклов друг за другом (длинно и уныло):

использовать Робот

алг

нач

нц пока справа свободно

вправо

кц

нц пока снизу свободно

вниз

кц

нц пока слева свободно

влево

кц

вниз

нц пока справа свободно

вправо

кц

нц пока снизу свободно

вниз

кц

нц пока слева свободно

влево

кц

кон


Написать программу для робота обязательно используя цикл пока. Условия для робота:слева свободноспра
0,0(0 оценок)
Ответ:
Davidavid
26.01.2021 19:20

PROGRAM Privet;

VAR

x:real;


BEGIN

writeln('Который час?'); read(x);

if x > 24 then

  writeln('Введенное число не является временем ' )

else

begin

if (x>=8) and (x<12)  then writeln('Доброе утро!');

if (x>=12) and (x<17)    then writeln('Добрый день!');

if(x>=17) and (x<23)    then writeln('Добрый вечер!');

if(x>=23) or (x<8)  then writeln('Доброй ночи!');

end;

end.

 

 

//вторая программа

var

  x,x1,x2,y,y1,y2:real;

begin

  write('x = '); readln(x);

  write('y = '); readln(y);

  write('x1 = '); readln(x1);

  write('y1 = '); readln(y1);

  write('x2 = '); readln(x2);

  write('y2 = '); readln(y2);

  if ((x - x1) * (x - x2) < 0) and ((y - y1) * (y - y2) < 0) then

    writeln('Точка принадлежит заданной области')

  else

    writeln('Точка не принадлежит заданной области');

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота