ник41111
04.06.2022 20:48

Напишите программу в паскаль: 3x-9, если x< =7 f(x)= 1/x(в квадрате)-4, если x> 7

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Neznaika123shsgwheh
09.03.2022 23:33
PYfy9pX4YibdfKzE8dnbSXaP3D5sbZenWQXx+TzottBxmrnKP4dS39zDFCHeytaxQuaxO6+SihcUhSqF6PmmxN3GxGIIAPLiSxjqjTtSHbvo7htEBwkC9DrKA9nK9xIOxPRcjpd6DAdMG0SkqPbK1+57wXgl2KsD43bDyI91iNHZGVEFuJjW2WjoZmDZOb/rVd7R9AqyWfNwqgLu5n0s8oZKpT55zvtPlOdDo6CM93h3C9G55Qj17fBXO/NNywpSzMGUqCxZha8Dm9QprL4Amawdo2pnCyu31Kn+Zny692acWR8k+IjeIoeL9HS7GGpxomAYoUcl2QOl2meKVWiovxtHmLKNooQK1Hc8yqvu293YHqgzQp3rHNgJxPJfiQnUmlYXGvOGZLk6vEUXIiesvdftDsCS/8Ae6YiLr8HWExGez9YXrworoX46BqS86+EFy3m8zwgu1fA9z61qLUP90KYw8KxlJJDWAThAVGrADHEsoHJ35+216/jwx5ruS3xgPOL83Vy5P1bL884jUiefVsuhprgR7C75lvy2ZCUYolQ=
0,0(0 оценок)
Ответ:
var  x, n: integer;  n1: real; begin  Writeln('Введите число: ');  Read(x);  if (x > 9) and (x < 100) then  begin    n := (x div 10) + (x mod 10);    Writeln('Сумма цифр равна: ', n);  end;  if (x > 99) and (x < 1000) then  begin    n := (x div 100) * ((x div 10) mod 10) * (x mod 10);    Writeln('Произведение цифр равно: ', n);  end;  if (x > 999) and (x < 10000) then  begin    n := x div 1000 + (x div 100) mod 10 + (x div 10) mod 10 + x mod 10;    n1 := n / 4;    Writeln('Среднее арифметическое равно: ', n1);  end;  if x > 9999 then  begin    Writeln('Введите 2-х, 3-х или 4-х значное число');  end; end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота