87056231946
17.05.2022 21:45

составьте программу вычисления суммы цифр введенного с клавиатуры
натурального числа ​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
KseniaSamarskaia15
11.01.2020 00:57
{предлагаю немного другой алгоритм решения}
Program Math;
var
x1,x2,d,e,f, a, b, c: real;
begin
writeln('Решение квадратного уравнения(ax^2+bx+c=0).');
write('Введите a: ');
readln(a);
write('Введите b: ');
readln(b);
write('Введите c: ');
readln(c);
d:=sqr(b)-4*a*c;
writeln('вы ввели:');
writeln('a=',a:6:2);
writeln('b=' ,b:6:2);
writeln('c=',c:6:2);
writeln(' Дискриминант: D=b*b-4*a*c=',d:6:2);
if (d>0)
then begin
e:= (-b/(2*a));
f:= (sqrt(d)/(2*a));
writeln('D>= 0, значит корни действительные: ');
writeln('x1= ',(e-f):6:2);
writeln('x2= ',(e+f):6:2);
end;
if (d=0) then writeln('D=0, значит уравнение имеет 1 корень: x1= ',-b/2*a:6:2);
if (d<0) then writeln(' D<0, корней нет ');
end.
Найти ошибку ( в паскале выдает false) - это программа по решению квадратного уравнения program math
0,0(0 оценок)
Ответ:
letochka111
07.02.2021 11:20
Program n1;
var
m, n: integer;
ms: array[1..9] of string;
md: array[1..9] of string;
m1: array[11..19] of string;
me: array[1..9] of string;
flag: boolean;
begin
flag := false;
ms[1] := 'сто'; ms[2] := 'двести'; ms[3] := 'триста'; ms[4] := 'Четыреста';
ms[5] := 'пятьсот'; ms[5] := 'пятьсот'; ms[6] := 'шестьсот'; ms[7] := 'семьсот';
ms[8] := 'восемьсот'; ms[9] := 'девятьсот';
md[1] := 'десять'; md[2] := 'двадцать'; md[3] := 'тридцать'; md[4] := 'сорок';
md[5] := 'пятьдесят'; md[6] := 'шестьдесят'; md[7] := 'семьдесят';
md[8] := 'восемьдесят'; md[9] := 'девяносто';
m1[11] := 'одиннадцать'; m1[12] := 'двенадцать'; m1[13] := 'тринадцать';
m1[14] := 'четырнадцать'; m1[15] := 'пятнадцать'; m1[16] := 'шестнадцать';
m1[17] := 'семнадцать'; m1[18] := 'восемнадцать'; m1[19] := 'девятнадцать';
me[1] := 'один'; me[2] := 'два'; me[3] := 'три'; me[4] := 'четыре'; me[5] := 'пять';
me[6] := 'шесть'; me[7] := 'семь'; me[8] := 'восемь'; me[9] := 'девять';

write('введите число: ');
readln(m);
if (m < 1) or (m > 1000) then writeln('число не входит в заданный интервал')
else
if m = 1000 then writeln('одна тысяча ')
else
begin
n := m div 100;
if n > 0 then
begin
write(ms[n]);
flag := true
end;
m := m mod 100;
if m = 0 then writeln(' ')
else
begin
if (m > 10) and (m < 20) then
begin
if flag then write(' ');
writeln(m1[m])
end
else
if m > 0 then
begin
n := m mod 10;
m := m div 10;
if m > 0 then
begin
if flag then write(' ') else flag := true;
Write(md[m])
end;
if n <> 0 then
begin
if flag then write(' ');
write(me[n]);
end
end
end
end
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота