Решить задачу на питоне Шли как-то два математика по лесу и собирали ягоды. Час шли, два шли, а потом вдруг остановились и решили ягодами помериться. Достали они весы (какой же математик пойдет в лес без весов?) и взвесили свои корзины с собранным урожаем, а потом записали полученные числа a 1 и b 1 на листочек. После этого второй математик пересыпал все ягоды в корзину к первому (полностью опустошив свою корзину), и они снова взвесили свои корзины, получив числа a 2 и b 2 соответственно. Наконец, первый математик пересыпал все ягоды в корзину ко второму (полностью опустошив свою корзину); после взвешивания они получили числа a 3 и b 3 соответственно. Этих данных оказалось достаточно для определения победителя, и довольные математики пошли дальше. Вам же предстоит вычислить массу ягод в корзине каждого из математиков до совершения всех пересыпаний. Формат ввода Входные данные состоят из трёх строк. В i -й строке ( 1 ≤ i ≤ 3 ) записаны целые числа a i и b i ( 0 ≤ a i , b i ≤ 10000 ) . Формат вывода В единственной строке выведите пару целых чисел через пробел - сколько ягод собрали, соответственно, первый и второй математик.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kokoulina68
07.03.2023 22:37
Стакан перемещается на третье место, соответственно чашка на четвертое. Теперь известно, что кофе оказалось посередине, т.е. оно в стакане. Справа и слева чай и молоко. Т.е. в кружке либо чай, либо молоко и в чашке тоже. Но известно, что в бутылке минеральная вода, а по соседству с молоком - квас. В чашке - молоко, в кувшине квас, в кружке чай.
                  кофе чай молоко квас минеральная вода
     бутылка  -        -      -           -        +
     кружка            +      
     чашка                    +    
     стакан    +        -      -          -         -
     кувшин                              +  
0,0(0 оценок)
Ответ:
Ghhgfgh
26.04.2021 01:14
// PascalABC.Net

function IsNice(n:longint):boolean;
// Отвечает на вопрос, является ли число красивым
var
  d,nd,sd:byte;
begin
  sd:=0; nd:=0;
  repeat
    d:=n mod 10;
    sd:=sd+d; Inc(nd);
    n:=n div 10
  until n=0;
  IsNice:=(sd mod nd = 0)
end;

var
  i,n,k:longint;
begin
  Write('Порядковый номер "красивого" числа: '); Read(n);
  i:=1; k:=0;
  repeat
    if IsNice(i) then Inc(k);
    if k<>n then Inc(i)
  until k=n;
  Writeln('Красивое число равно ',i)
end.

Тестовое решение:
Порядковый номер "красивого" числа: 15
Красивое число равно 20
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота