sprinter99
15.09.2022 14:00

Напишите программу, которая выводит на консоль простые числа в промежутке от [2, 100]. Используйте для решения этой задачи оператор “%” (остаток от деления) и циклы. Используйте циклы с метками.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
викусямиуся
30.12.2022 06:58
Const
  nmax = 99;

var
  i, n, k, s: integer;
  a: array[1..nmax] of integer;

begin
  Randomize;
  Write('Введите количество элементов массива (1-99)');
  Readln(n);
  Write('Введите число k ');
  Readln(k);
  Writeln('Исходный массив');
  s := 0;
  for i := 1 to n do
  begin
    a[i] := Random(98) + 1;
    Write(a[i]:3);
    if (a[i] mod k) = 0 then s := s + a[i]
  end;
  Writeln(#13#10, 'Сумма элементов, кратных ', k, ' равна ', s)
end.

Тестовое решение:

Введите количество элементов массива (1-99)12
Введите число k 3
Исходный массив
 34 63 18 81 91 83 83 80 10 59 81 74
Сумма элементов, кратных 3 равна 243
0,0(0 оценок)
Ответ:
iiklyminecraft
15.08.2021 08:57
#include <iostream> /*Заголовочный файл, который отвечает за потоковый ввод/вывод (cout/cin).*/
#include <cstdlib>/*Заголовочный файл, подключается для функции system().*/
using namespace std;/*Пространство имен std. Все имена стандартных функций расположены именно в этом пространстве имен.  */
int main() { //Начало главной программы.

int n; /*Количество чисел в массиве а и b.*/
float sum=0; //Переменная, которая отвечает за сумму.

cout<<"Vvedite n: "; /*Ввод количества элементов массива. (Тут ошибка,
если вы хотите вводить количество элементов массива, вам нужно использовать динамическое выделение памяти. То есть, float *a = new float [n], тогда эти две строки пойдут. А так лучше задать константную размерность двух массивов (const int n = 10 (например))).*/

cin>>n;

float a[n+1], b[n+1]; /*Массивы.*/

/*Теперь идет запись элементов в массив A, индекс пробегает по каждому 
элементу массива записывает значение, которое вводит пользователь.*/
for (int i=1; i<=n; i++){
system("cls"); /*Очищение консоли (экрана).*/
cout<<"Vvedite "<<i<<"-e chislo massiva a: "; /*На экран выбивает сообщение пользователю, что бы он ввел с клавиатуры значения a[i] элемента.*/ 
cin>>a[i]; /*Ввод значения с клавиатуры.*/

sum+=a[i]; /*Добавление элемента к сумме. (sum = sum+a[i])*/

b[i]= sum/i; /*Запись в массив b. */
}

system("cls"); /*Очищение экрана.*/

 /* Вывод массива b.*/
cout<<"B = [";
{
for (int i=1; i<n; i++)
cout<<b[i]<<", ";
}

cout<<b[n]<<"] "; 

system("pause"); /*Если не будет этой строчки, экран (консоль) будет сразу же закрываться. Вы не успеете ничего прочитать.*/
return 0; /*Используется для возврата значения (так как main типа int).*/
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота