Nikitosqwerty
17.07.2020 13:50

Решить с использованием pascalabc 1) написать программу, которая по году рождения человека определяет к какой из 3 возрастных категорий он относится: ребенок (до 18 лет), в полном расцвете сил (до 70 лет), умудрен опытом( свыше 70 лет). 2) известны длины всех сторон треугольника. составьте программу, проверяющую, является ли треугольник прямоугольным.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
postnovat
05.03.2023 14:59

Цикл while i > 1 do begin означает что он будет выполняться до тех пор, пока i > 1. i изначально равно 7, и в конце каждого выполнения число уменьшается на единицу (i:=i-1). i div 2 означает деление числа на 2 с целым остатком. Исходя из вышесказанного имеем:

(Каждое выполнение цикла буду обозначать как №)

№1: 7>1 (Истина)

S:=0+3=3

i=6

№2: 6>1 (Истина)

S:=3+3=6

i:=5

№3: 5>1 (Истина)

S:=6+2=8

i:=4

№4: 4>1 (Истина)

S:=8+2=10

i:=3

№5: 3>1 (Истина)

S:=10+1=11

i:=2

№6: 2>1 (Истина)

S:=11+1=12

i:=1

№7: 1>1 (Ложь)

Вывод числа S со значением 12.

ответ: 12.

0,0(0 оценок)
Ответ:
Sonta0004
08.11.2022 05:18
1. Примерно так учат писать программы в большинстве школ

var
  n,s:integer;

begin
  s:=0;
  repeat
    Read(n);
    if n<>0 then
      if (n mod 6=0) and (n mod 10=2) then s:=s+n
  until n=0;
  Writeln(s)
end.

Пример
16
42
18
132
94
18
0
174

Кроме этого, зачем-то требуют блок-схему  - приведена во вложении, выполнена по ГОСТ 19.701-90 (ISO 5807-85).

2. А вот так эту задачу можно решить в современном Паскале

PascalABC.NET 3.3.5, сборка 1660 от 20.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  ReadSeqIntegerWhile(t->t<>0)
      .Where(t->(t mod 6=0) and (t mod 10=2)).Sum.Println
end.

И блок-схема тут вообще не нужна: она ничего не даст.

Сравнение явно не в пользу школьного "образования" - учить, как выполнять работу двадцать минут вместо двух.

На ! написать программу, которая в последовательности натуральных чисел определяет сумму всех чисел,
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота