биг8
21.05.2023 07:33

Составить программу с оператором case , которая определяет день недели(пн(1)...вс(7)), всего дней 366

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Arinakap22
15.10.2020 18:04

#include <iostream>

using namespace std;

void findDayOfWeek(int day) {

switch (day) {

 case 1:

  cout << "Понедельник";

  break;

 case 2:

  cout << "Вторник";

  break;

 case 3:

  cout << "Среда";

  break;

 case 4:

  cout << "Четверг";

  break;

 case 5:

  cout << "Пятница";

  break;

 case 6:

  cout << "Суббота";

  break;

 case 7:

  cout << "Воскресенье";

  break;

 default:

  findDayOfWeek(day - 7);

}

}

int main() {

setlocale(0, "RU");

int day;

cin >> day;

findDayOfWeek(day);

return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота