dzavad1
29.07.2021 11:38

Задание по информатике. Напишите программу 3 двоек при процедуры.​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
EM20011
30.06.2020 23:34
Program exp3;
uses crt;
const
  m = 5;
  n = 3;
type
  matr = array [1 .. m, 1 .. n] of integer;
var
  A: matr;
  b, i, j, k: integer;
begin
  clrscr;
  randomize;
  for i := 1 to m do
  begin
    for j := 1 to n do
    begin
      A[i, j] := random(101);
    end;
  end;
  k := n div 2;
  for j := 1 to k do
  begin
    for i := 1 to m do
    begin
      b := A[i, j];
      A[i, j] := A[i, n - j + 1];
      A[i, n - j + 1] := b;
    end;
  end;
  for i := 1 to m do
  begin
    for j := 1 to n do
    begin
      write(A[i,j]: 5) ;
    end;
    writeln;
  end;
    readln;
end.
0,0(0 оценок)
Ответ:
Kamaria086
05.11.2021 00:54
Алгоритм:
Объявляем 4 переменные вещественного типа и считываем их.
Выводим математическую формулу, для вычисления стоимости.
Количество бензина на 1 км пути * удвоенное расстояние до дачи * цена бензина.

Ниже приведена программа на языке Паскаль

var
S, count, price, ans:real;
Begin
Writeln('Введите расстояние до дачи -> ');Readln(s);
Writeln('Введите расход бензина на 100 км пути -> ');Readln(count);
Writeln('Введите цену бензина -> ');Readln(price);
ans:= ((count/100)* 2*s * price );
Writeln('Стоимость поездки: ', ans);
end.

Пример:
Введите расстояние до дачи ->
28.54
Введите расход бензина на 100 км пути ->
13.1
Введите цену бензина ->
45
Стоимость поездки: 336.4866
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота