elvinsasylbaeva
02.04.2023 10:42

Нужно сделать это в паскале: "составьте программу, реализующую алгоритм перестановки по следующему правилу. исходный текст записывается в табличку строчками по 15 букв. шифрованный текст получается чтением текста из таблицы по столбцам. если последняя строка содержит меньше 15 букв, дополнить ее любыми символами алфавита (одинаковыми). результат выводится на экран. знаки препинания и цифры в таблицу не вносятся."

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
uchikha2016
25.05.2020 20:06
Program spos;
uses crt;
var
numb:array [1..100] of byte; // для последовательности чисел
i,f:integer; //счетчик и переменная в качестве флага
begin
randomize;
f:=0;
for i:=1 to 100 do numb[i]:=random(101);// задает последовательность

for i:=1 to 100 do
begin
write(',',numb[i]); // вывод на экран последовательность(можно удалить)
if (numb[i]=77)then f:=1; // в случае удачной проверки f:=1, в противном останется 0
end;
if f=0 then writeln('Yes') else writeln('No');

end.

program spos;
uses crt;
var
numb:array [1..100] of byte; // для последовательности чисел
i,f:integer; //счетчик и переменная в качестве флага
begin
randomize;
f:=0;
for i:=1 to 100 do begin
numb[i]:=random(101);// задает последовательность
write(' ',numb[i]);//вывод на экран, можно удалить
end;
writeln;
i:=0;
repeat
i:=i+1;
if (numb[i]=77)then f:=1; // в случае удачной проверки f:=1, в противном останется 0
until i<100;
if f=0 then writeln('Yes') else writeln('No');

end.
0,0(0 оценок)
Ответ:
kushkulina2011
30.05.2023 08:32

К моменту завершения K-го урока пройдёт K собственно уроков и (K - 1) перемена. Вычисляем продолжительность в минутах, делим с остатком на 60 - число минут в часе - и получаем количество часов и минут, которые пройдут с начала занятий. Остаётся прибавить к этому 8 часов - время начала занятий - и вывести ответ.

python 3:

MINS_IN_HOUR = 60

mins_in_class, mins_in_break = 45, 5

start_hour = 8

k = int(input())

total_mins = k * mins_in_class + (k - 1) * mins_in_break

hour, mins = divmod(total_mins, MINS_IN_HOUR)

print(hour + start_hour, mins)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота