Matthi
26.01.2022 13:47

Создать объект, который обрабатывает массив целых чисел не более 10 элементов.количество элементов определяется в момент конструирования объекта.объект обладает следующей функциональностью: - считывает элементы массива - выводит элементы массива - разворачивает последовательность элементов массива. написать программу, которая: 1. создаёт и в конструкторе считывает количество элементов массива. 2. считывает элементы массива. 3. выводит значения элементов массива согласно исходной последовательности 4. разворачивает элементы массива. 5. выводит значения элементов массива согласно новому их порядку следования. язык программирования c++

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Svetbor04
30.03.2023 20:28
// PascalABC.NET 3.3, сборка 1625 от 17.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadReal('Введите число a:');
  var n:=ReadInteger('Введите показатель степени n:');
  if n<=0 then begin
    Writeln('Показатель степени должен быть натуральным числом');
    Exit
    end;
  // перевод показателя степени в двоичную систему счисления
  var t:=n;
  var r:string:='';
  while t>=2 do (r,t):=(t mod 2+r,t shr 1);
  r:=t+r;
  // возведение в степень
  var (rr,i):=(a,2);
  while i<=r.Length do begin
    rr:=Sqr(rr);
    if r[i]='1' then rr*=a;
    i+=1
    end;
  Writeln(a,'^',n,' = ',rr)  
end.

Примеры
Введите число a: 3.182
Введите показатель степени n: 11
3.182^11 = 338611.675261463

Введите число a: 2
Введите показатель степени n: 10
2^10 = 1024
0,0(0 оценок)
Ответ:
TheOll
15.11.2020 04:57
Код#include <iostream>#include <string>#include <functional>std::string switch_first_and_last(std::string N) {    auto L = N.size() - 1;    return N[L] + N.substr(1, L - 1) + N[0];}bool take_correct_number(int &number, const std::function<bool(int)>& Q) {    do {        std::cin >> number;        if (!Q(number)) {            std::cout << "Try again." << std::endl;            continue;        }        break;    } while (true);    return true;}int main() {    int number;    take_correct_number(number, [](int x){return x > 9;});    std::cout << switch_first_and_last(std::to_string(number)) << std::endl;}
Программа получает на вход натуральное число, большее 9. Вывести число, которое получится в результа
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота