bekker222
18.05.2021 10:00

задача: напишите программу выводящих на экран список всех программистов и дополнительный список программистов на С++ решить нужно через записи , программу написать на паскаль авс.net сома программа ниже но вместо списка выводится белый экран. то есть программа завершается на слове ввод закончен что не так? Type pr=record nm:string; Ln:string; end; var prog:array[1..3]of pr; i:integer; begin for i:= 1 to 3 do begin Writeln(' Введите Фамилию и имя ',i,'человека'); Readln(prog[i].nm); Writeln(' Введите язык'); Readln(prog[i].Ln); end; Writeln('вВОД ЗАКОНЧЕН'); for i:= 1 to 3 do if prog[i].Ln= 'C ++' then Write(prog[i].Ln); end.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
pumpus
20.03.2021 06:52
 program z1;
 var n,m:integer;
 rost,nine_a,nine_b:real;
 begin
write('Введите количество учинеков 9а класса: ');
readln(n);
write('Введите количество учинеков 9б класса: ');
readln(m);
writeln('Вводите рост каждого из учинеков 9а по очереди');
for i:integer :=1 to n do begin
write(i,': ');
read(rost);
nine_a:=nine_a+rost;
end;
nine_a:=nine_a/n; // средний рост 9а
writeln('Вводите рост каждого из учинеков 9б по очереди');
for i:integer :=1 to m do begin
write(i,': ');
 read(rost);
nine_b:=nine_b+rost;end;
nine_b:=nine_b/n; // средний рост 9б
if nine_a > nine_b then write('Средний рост учеников 9а больше.') else if nine_a < nine_b then write('Средний рост учеников 9б больше.') else write('Средний рост учеников 9а равен среднему росту учеников 9б.');
end.

как-то так, будут вопросы пиши)
Всего-то 30 мин
0,0(0 оценок)
Ответ:
Yana6hhhh
01.01.2023 10:20
Const
  n = 15;

var
  i: integer;
  a: array[1..n] of integer;

begin
  Randomize;
  writeln('Исходный массив');
  for i := 1 to n do
  begin
    a[i] := Random(100) - 50;
    write(a[i]:6);
    if a[i] < 0 then a[i] := sqr(i)
  end;
  writeln;
  writeln('Результирующий массив');
  for i := 1 to n do write(a[i]:6);
  writeln
end.

Тестовое решение:

Исходный массив
     3    37    40    17    20   -12   -27     4    34    -1     9    42    -6   -36    28
Результирующий массив
     3    37    40    17    20    36    49     4    34   100     9    42   169   196    28
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота