Evelina17890
09.08.2020 14:28

Написать программу вычисления корней квадратного уравнения ах^2 + bx + c=0. Коэффициенты а, b, с вводятся с экрана. Программа должна вычислить как действительные, так и комплексные корни и вывести результат на экран в привычном для пользователя виде (например, х1=0.5+0.8661; х2=0.5-0.866i). В вычисления запрашивать, завершить работу или решить квадратное конце уравнение еще раз

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Dote8228
17.08.2020 23:01

На C++:

#include <iostream>

#include <cmath>

using namespace std;

int main() {

setlocale(0, "RU");

int a, b, c;

cout << "Введите коэффициенты уравнения: ";

cin >> a >> b >> c;

cout << "D = b^2 - 4 * a * c\n";

cout << "D = " << b * b << " - " << 4 * a * c << endl;

double D = (b * b) - (4 * a * c);

cout << "D = " << D << endl;

int d = sqrt(D);

cout << "vD = " << endl << endl;

 

 

a *= 2;

int x1 = (-b - d) / a;

int x2 = (-b + d) / a;

cout << "x1 = (-b - vD) / 2a = " << x1 << endl;

cout << "x2 = (-b + vD) / 2a = " << x2;

return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота