anasstasissya
10.06.2022 19:55

Нужно написать программу в Pascal: пользователь вводит число в десятичной системе, а программа должна перевести это число в двуичный код. Желательно сделать 1 программу простой, с использованием if, div, mod, ну и циклы если надо,кроме цикла repeat, например пользователь ввёл 5 а система перевела в двуичный код 101

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
mary2005super
15.09.2020 06:47

program ToBinary;

procedure dec2bin(var s : string; num : integer);

begin

   if num > 0 then begin

       dec2bin(s, num div 2);

       if num mod 2 = 0 then

           s := s + '0'

       else

           s := s + '1';

   end;

end;

var

 a : integer;

 s : string;

begin

 read(a);

 dec2bin(s, a);

 writeln(s);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота