aselja228
31.03.2020 01:50

1. подготовить файл input.txt (с числом). написать программу, которая считает из файла число и возведет его в квадрат. вывести квадрат числа в файл output.txt. 2.найти сумму цифр чисел, записанных в файл. 3.подготовить файл input1.txt (с числом). написать программу, которая считает из файла два числа. вывести на экран наибольшее из двух чисел.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Daney213
13.05.2019 15:00

ответ:

объяснение:

var f1,f2: text; a,i,k: integer;

begin

assign(f1,'input.txt');

reset(f1);

assign(f2,'output.txt');

rewrite(f2);

readln(f1,a);

k: =0;

for i: =2 to round(sqrt(a)) do 

  if a mod i=0 then k: =k+1;

if k=0 then writeln(f2,a,' - простое число')

else writeln(f2,a,' - составное число');

close(f1); close(f2);

end.

пример:

файл input.txt:

43

файл output.txt:

43 - простое число

подробнее - на -

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота