тяпница13
18.05.2020 10:39

решить задачи на языке программирования Delphi. Задача 1. Задан массив A(N,N), заполненный целыми случайными числами из диапазона [-27;28]. Найти произведение ненулевых элементов массива.

Задача 2. Задан массив A(N), заполненный случайными целыми числами из диапазона [-18,24]. Составить программу нахождения третьего отрицательного элемента массива.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
dkrutov03
01.07.2022 05:13

1.

var

  A: array [1..10] of integer;

  max, i: integer;

begin

    for i:=1 to 10 do                 // заполнение массива

        A[i] := random(100) - 50;

    max := -51;

    for i:=1 to 10 do                 // обработка массива

        if (A[i] < 0) and (A[i] > max) then

        max := A[i];

    writeln(max);

end.

2.

var

  A: array [1..1000] of integer;

  kol, i, N: integer;

begin

    readln(N);

    for i:=1 to N do                 // заполнение массива

        A[i] := random(100) - 50;

    for i:=1 to N do                 // обработка массива

        if A[i] mod 2 = 0 then

        inc(kol);

    writeln(kol);

end.

0,0(0 оценок)
Ответ:
Писинчик
22.07.2022 14:18

1 конечная последовательность шагов в решении , приводящая от исходных данных к

требуемому результату. 1 1 за правильное определение

алгоритма.

2 b, c 2 1 за каждый

правильный ответ

3  

№ команда

⦁ c) выберите оператора

⦁ b) введите номер телефона

⦁ a) проверьте и подтвердите номер телефона

⦁ e) введите в окно «сумма оплаты»

⦁ d) внесите купюры в купюроприёмник (возможно ввод нескольких купюр)

⦁ h) нажать кнопку «оплатить»

⦁ g) дождитесь распечатки чека

⦁ f) перейдите в окно «главная»

3.1) 1. c), 2. b), 3. a), 4. e),   5. d), 6. h), 7. g),   8. f)

.

3.2) система команд исполнителя 2 2     за   полностью

    правильную

    последовательность.

    1 за 4 правильные

    последовательности.

   

1     за правильный

    ответ

  1  

4 словесная запись алгоритма 1 1 за правильный ответ

5   1 пп 6 и1 11 пл   2 1 за поворот на лево

1 за команду идти 2 шага

    2 и4 7 пп 12 и2      

    3 пл 8 и1 13 пл      

    4 и1 9 пп 14 и2      

    5 пл 10 и1 15 с      

6 6.1) разветвляющийся алгоритм 1 1     за правильный

  тип алгоритма

6.2) алгоритм выполнение которого зависит   от  

проверки некоторых условий называется 2 1     за определение

разветвляющимся алгоритмом.   разветвляющего

в   данной   программе   проверяется правильный   алгоритма   и   1   за

ответ   «гадкий   утёнок», если ответ верный,   то   описание фрагмента

звучит   соответствующая   музыка   и   этот   ответ   кода программы

получает значение переменной 1, а иначе ответ неверный звучит другая музыка и значение переменной присваивается 2 (для подсчёта правильных ответов).

примечание: принимается ответ ученика, если он описывает как проходит проверка, без подсчёта переменной.   ветвления.

7  

  4 1 за блок цикла

1 за блок присвоения

1 за команду

1 за команду

8 движение объекта. создание простой анимации в игровой среде. объект будет двигаться постоянно, дойдя до края оттолкнётся и

обратно будет двигаться. 1 1 за правильный ответ

9   2 1 за правильное определение координаты;

1 за правильное направление спрайта

10   команда         1 1     за   правильное

определение команды

    место

для отметки          

итого   20  

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота