alexey2006kost
21.09.2020 12:44

нужно написать программу Вычислить:

10

S=å(xi3+8)0.5 , где xi=xi-1+dx2; x1=2; dx=0.2.

i=1

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
galuhlulia
04.04.2020 12:30
Если матрица подаётся построчно (вводить числа без [] разделённые пробелом)

# input

matrix = []

line = list(map(int, input().split()))

matrix.append(line)

for j in range(len(line) - 1):

   line = list(map(int, input().split()))

   matrix.append(line)

print(matrix)

# k + max

k = int(input("k: "))

maximum = matrix[0][0]

counter = 0

for arr in matrix:

   for num in arr:

       if num % k == 0:

           if maximum < num:

               maximum = num

           counter += 1

print("{0} чисел, кратных {1}".format(counter, k))

if maximum != 0:

   print("Максимальное число кратное {0} - {1}".format(k, maximum))

else:

   print("Нет чисел кратных {0}".format(k))

Если одной строкой, уже массивом ([1,20,3,4],[2,5,5,5],[3,8,9,12],[8,9,10,11])

# input

matrix = input().split("],[")

matrix[0] = matrix[0][1:]

matrix[len(matrix) - 1] = matrix[len(matrix)-1][:len(matrix[len(matrix) - 1])-1]

newMatrix = []

for arr in matrix:

   line = list(map(int, arr.split(",")))

   newMatrix.append(line)

matrix = newMatrix

print(matrix)

# k + max

k = int(input("k: "))

maximum = matrix[0][0]

counter = 0

for arr in matrix:

   for num in arr:

       if num % k == 0:

           if maximum < num:

               maximum = num

           counter += 1

print("{0} чисел, кратных {1}".format(counter, k))

if maximum != 0:

   print("Максимальное число кратное {0} - {1}".format(k, maximum))

else:

   print("Нет чисел кратных {0}".format(k))


В Python с двумерных массивов, решите задачу: Для целочисленной квадратной матрицы найти число элеме
В Python с двумерных массивов, решите задачу: Для целочисленной квадратной матрицы найти число элеме
0,0(0 оценок)
Ответ:
karinakarim
02.01.2023 13:44

1) Не достаточно информации

2)

Program help1;
Uses Crt;
Var a : Array[1..3, 1..3] of Integer;
i, j, m : Integer;

Begin
ClrScr;

For i := 1 to 3 do
For j := 1 to 3 do
Begin
Write('Введи a[', i, ', ', j, ']: ');
Readln(a[i, j]);
End;

If a[1, 1] > 0 then
m := 4;
If a[1, 1] < 0 then
m := 7;

For i := 1 to 3 do
For j := 1 to 3 do
a[i, j] := a[i, j] * m;
End.

3)

Program help2;
Uses Crt;
Var s : String;
n, i : Byte;

Begin
ClrScr;

Write('Введи строку: ');
Readln(s);

n := 0;

For i := 1 to Length(s) do
if s[i] = '5' then
inc(n);

Write('Цифра 5 встречается ', n, ' раз');
End.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота