ульянка37
10.10.2022 04:20

написать программу на заранее. Дана числовая последовательность: {a1=0, a2=4, …, an=an-1-3an-2}. Найти сумму отрицательных элементов при n=25. Исходные данные: количество элементов n - целый тип, значение х - an-2 целый тип, y - an-1 целый тип. Результат: Сумма отрицательных элементов S – целый тип. Для вычисления нового значения an необходимо знать 2 предыдущих значения. Для получения нового значения an надо знать an-1 и an-2 , которые необходимо сохранять в дополнительных переменных. Тестовый пример: с получаем S= -1644128


написать программу на заранее. Дана числовая последовательность: {a1=0, a2=4,

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
serzhsitch
19.09.2021 07:40

#include <iostream>

#include <stack>

using namespace std;

void solve(string &s){

   stack<char> cur;

   for(int i = 0; i < s.size(); i++){

       if(!cur.empty() && ((cur.top() == '(' && s[i] == ')') || (cur.top() == '{' && s[i] == '}') || (cur.top() == '[' && s[i] == ']')))

           cur.pop();

       else cur.push(s[i]);

   }

   if(cur.empty()) cout << "YES";

   else cout << "NO";

}

signed main() {

   string str;

   cin >> str;

   solve(str);

}

0,0(0 оценок)
Ответ:
dianadavletova
06.09.2020 23:27

В оглавлении произведения, разбитого на части, разделы, подразделы, главы, подглавы, параграфы, подпараграфы, примечания и т. п., устанавливающие соподчиненность отдельных частей произведения, последовательно приводятся наименования частей, разделов, глав, параграфов в полном объёме, так, как они даны в тексте, и указываются страницы, на которых начинается рубрика. Рубрики последней ступени — подзаголовки, взятые в тексте рукописи в подбор, — в оглавлении могут не приводиться. Взаимоподчиненность частей произведения в оглавлении передают средствами полиграфического оформления: выделением в красную строку, шрифтами и набором рубрик с отступом от левого края полосы

В отличие от содержания, характеризующего состав сборника произведений, оглавление раскрывает в первую очередь строение произведения в моноиздании (роман, повесть, и т. д.) или только строение сборника (из каких частей или разделов он состоит)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота