Posrednikova04
21.07.2021 05:03

Задано массив [2,7,3]. Написать программу на языке Java, которая вычислит среднее арифметическое элементов массива

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nata1316
15.10.2020 15:08

public class Main

{

public static void main(String[] args) {

    int x = 0;

    int[] mas = {2,7,3};

    for(int i = 0; i < mas.length; i++){

       x = x + mas[i];

    }

    int res = x/mas.length;

 System.out.println(res);

}

}

Объяснение:

public class Main

{

public static void main(String[] args) {

    int x = 0;

    int[] mas = {2,7,3}; //     объявляем массив

    for(int i = 0; i < mas.length; i++){

       x = x + mas[i]; //      Цикл, который берет каждое число массива(mas[i]), и плюс с предыдущим(2+7+3)

    }

    int res = x/mas.length;    //     x делится на длину массива(3)

 System.out.println(res); //     Вывод результата

}

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота