geo2015brosto
04.01.2022 05:25

Составить программу на C++ для решения следующей задачи. Дан массив А, состоящий из 10 действительных чисел. Обменять местами минимальный и последний элемент массива. Массив заполнить с клавиатуры и вывести на экран.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
4sasna
15.10.2020 15:05

#include <iostream>

#include <vector>

using namespace std;

void swap(int *a, int *b){

   int temp = *a;

   *a = *b;

   *b = temp;

}

signed main() {

   const int n = 10;

   vector<int> a(n);

   int mx = -INT_MAX, mn = INT_MAX, i = 0, j = 0;

   for(int k = 0; k < n; k++){

       cin >> a[k];

       if(a[k] > mx){mx = a[k]; i = k;}

       if(a[k] < mn){mn = a[k], j = k;}

   }

   swap(a[i],a[j]);

   for(auto &i:a)

       cout << i << " ";

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота