2008анна22031
10.12.2020 09:48

4. Написать программу, которая анализирует данные о возрасте и относит человека к одной из четырех групп: дошкольник, школьник, рабочий, пенсионер. Подсказка: используйте логические операторы И (&&), ИЛИ (||), НЕ (!). дошкольник = 60 Язык СИ

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
masha2820
25.06.2021 12:58

Сорян паскаль не знаю , могу скинуть на С++

Разбираешься в инфе , поймёшь

#include <iostream>

using namespace std ;

int main {

\\ не важно что выше

 

int num , k , o , s , l; \\ объявляем числа  

l, o , s , k ,num = 0 ;  \\ чтобы в компиле гадости не было

cin >> num >> k ; \\ вводим их c клавы

while (num >= 1) {

 s = num ;

 o = s%10 ;

     if (o <= k){ // цикл на проверку условию задачи

     l += 1 ;

     }

 num = num % 10 ;

}

cout << l ; // выводим ответ

\\ не важно что ниже

return 0 ;

}

0,0(0 оценок)
Ответ:
MarinaKim111
24.07.2022 21:30
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a,b,c:real;
  Read(a,b,c); // не вводить одинаковых!
  if a>b then
    if a>c then // a > [b,c]
      if b>c then Writeln('Среднее - второе число')
      else Writeln('Среднее - третье число')
    else Writeln('Среднее - первое число')
  else
    if b>c then // b > [a,c]
      if a>c then Writeln('Среднее - первое число')
      else Writeln('Среднее - третье число')
    else Writeln('Среднее -  второе число')
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота