darilinamoo
04.01.2022 21:08

Напишите программу сортировки массива строк по убыванию длины (на c++).Заранее

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
k03a12345
15.10.2020 14:50

#include <iostream>

#include <vector>

using namespace std;

bool comp(string s1, string s2){

   return s1.length() > s2.length();

}

signed main() {

   int n;

   cin >> n;

   vector<string> a(n);

   for(auto &i: a)

       cin >> i;

   sort(a.begin(),a.end(),comp);

   for(auto &i:a)

       cout << i << ' ';

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота