Саняша69
12.02.2023 05:12

Нужно составить программу на языке Delphi или Pascal, которая находит произведение всех ненулевых элементов двухмерного массива и их общее количество.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
grizzly15
03.08.2022 04:29

Циклы, в которых действия повторяются определенное количество раз, называются циклом со счетчиком

Вопрос №2 ?

Каким оператором описывается цикл с параметром в языке программирования Python? for

Вопрос №3 ?

Синтаксис цикла со счетчиком выглядит следующим образом: for i in range (n):

Вопрос №4 ?

Переместить исполнителя на 10 шагов вперед в предварительно заданном направлении можно с команды fd (10)

В следующих вопросах недостаточно информации для ответа(

Вопрос №5 ?

Что будет напечатано в результате выполнения фрагмента программы? 001224 245678 012345 002121

Вопрос №6 ? Чему будет равно S после выполнения фрагмента программы? 1 4 6 2

0,0(0 оценок)
Ответ:
NikNameXxX
29.10.2020 11:35
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
  var m:=Readinteger('Что ищем?');
  var k:=a.FindAll(x->x=m).Count;
  Writeln('Найдено таких элементов- ',k);
  if k>0 then Writeln('Номер первого такого элемента- ',
    a.FindIndex(x->x=m)+1)
end.

Пример
n= 17
-46 33 -9 -22 14 -46 -6 -3 -7 -18 46 42 -40 -40 0 29 -9
Что ищем? -9
Найдено таких элементов- 2
Номер первого такого элемента- 3
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота