dudich97
20.05.2022 10:26

написать программу в Pascal 25 вариант


написать программу в Pascal 25 вариант

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Лідія200445
11.06.2021 08:06
//1a

Var
 i,x1,x2:integer;
begin
 for i:=10 to 99 do
  begin
   x1:=i mod 10;
 x2:=i div 10;
   if (sqr(x1)+sqr(x2)) mod 13=0 then writeln(i);
  end;
end.

//1б
Var
 i,x1,x2:integer;
begin
 for i:=10 to 99 do
  begin
   x1:=i mod 10;
   x2:=i div 10;
   if x1+x2+sqr(x1+x2)=i then writeln(i);
  end;
end.

//2
Var
 i,n,a,k1,k2:integer;
begin
 readln(n);
 for i:=1 to n do
  begin
   readln(a);
   if a<1985 then k1:=k1+1;
   if a>1990 then k2:=k2+1;
  end;
 writeln('Родившиеся до 1985:',k1);
 writeln('Родившиеся после 1990:',k2);
end.
0,0(0 оценок)
Ответ:
OwL505
10.08.2022 23:04

Відповідь:

#include<iostream>

class Money{

public:

Money(){

 register unsigned int amount;

 std::cout<<"Введите количество рублей: \n";

 std::cin>>amount;

 if(amount%10!=0){

  std::cout<<"\nЯ не могу разбить эту сумму!";

 }

 else{

  std::cout<<"Я могу разбить эту сумму на минимальную, которая состоит из "<<amount/100+amount%100/50+amount%50/10<<" купюр:\n---"

           <<amount/100<<" купюр достоинством в 100 рублей\n---"<<

           amount%100/50<<" купюр достоинством в 50 рублей\n---"<<

           amount%50/10<<" купюр достоиством в 10 рублей";

 }

}

};

int main(){

setlocale(0,"");

Money money;

return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота