Thandey
21.03.2022 12:08

Составить программу обработки списка (массива) М, состоящего из 10 элементов. Все элементы массива М, значения которых находятся в интервале от -5 до 10 возвести в квадрат. Измененный массив вывести на экран.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
steamlox1
15.10.2020 14:44

arr = [int(i) for i in input().split()]

new_arr = []

for i in arr:

  if i>=-5 and i<=10:

       new_arr.append(i**2)

   else:

        new_arr.append(i)

[print(i, end=" ") for i in new_arr]

Краткий гайд:

arr -  исходный списокnew_arr - измененный список
Составить программу обработки списка (массива) М, состоящего из 10 элементов. Все элементы массива М
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота