shevyakova2018
30.06.2020 14:11

Напишите код в Python Вдоль прямой выложены три спички. Необходимо переложить одну из них так, чтобы при поджигании любой спички сгорали все три. Для того чтобы огонь переходил с одной спички на другую, необходимо чтобы эти спички соприкасались (хотя бы концами). Требуется написать программу, определяющую, какую из трех спичек необходимо переместить.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
polanovikova
17.02.2020 03:05

Цикл while также используется для повторения частей кода, но вместо зацикливания на n количество раз, он выполняет работу до тех пор, пока не достигнет определенного условия. Давайте взглянем на простой пример:

Python

i = 0

while i < 10:

   print(i)

   i = i + 1

1

2

3

4

i = 0

while i < 10:

   print(i)

   i = i + 1

Цикл while является своего рода условным оператором. Вот что значит этот код: пока переменная i меньше единицы, её нужно выводить на экран. Далее, в конце, мы увеличиваем её значение на единицу. Если вы запустите этот код, он выдаст от 0 до 9, каждая цифра будет в отдельной строке, после чего задача будет выполнена. Если вы удалите ту часть, в которой мы увеличиваем значение i, то мы получим бесконечный цикл. Как правило – это плохо. Бесконечные циклы известны как логические ошибки, и их нужно избегать. Существует другой вырваться из цикла, для этого нужно использовать встроенную функцию break. Давайте посмотрим, как это работает:

Python

while i < 10:

   print(i)

   

   if i == 5:

       break

   

   i += 1

1

2

3

4

5

6

7

while i < 10:

   print(i)

   

   if i == 5:

       break

   

   i += 1

В этой части кода мы добавили условное выражение для проверки того, равняется ли когда-либо переменная i цифре 5. Если нет, тогда мы разрываем цикл. Как вы видите в выдаче кода, как только значение достигает пяти, код останавливается, даже если мы ранее указали while продолжать цикл, пока переменная не достигнет значения 10. Обратите внимание на то, что мы изменили то, как мы увеличиваем значение при Это удобный ярлык, который вы можете также использовать в других операциях, таких как вычитание -= и умножение *=. Встроенный break также известен как инструмент управления потока. Существует еще один, под названием continue, который в основном используется для пропуска итерации, или перейти к следующей итерации. Вот один из его применения:

Python

i = 0

while i < 10:

   if i == 3:

       i += 1

       continue

   

   print(i)

   if i == 5:

       break

   

   i += 1

1

2

3

4

5

6

7

8

9

10

11

12

i = 0

 

while i < 10:

   if i == 3:

       i += 1

       continue

   

   print(i)

   if i == 5:

       break

   

   i += 1

Слегка запутанно, не так ли? Мы добавили второе условное выражение, которое проверяет, не равняется ли i трем. Если да, мы увеличиваем переменную и переходим к следующему циклу, который удачно пропускает вывод значения 3 на экран. Как и ранее, когда мы достигаем значения 5, мы разрываем цикл. Существует еще одна тема, касающаяся циклов, которую нам нужно затронуть – это оператор else.

0,0(0 оценок)
Ответ:
KimSoyu
09.05.2021 13:34

program fantscrin;


   const n = 10;


   var a: array [1..n] of integer;


       b: array [1..n] of integer;


       max_a,max_b,i,k:integer;


begin


   for i:=1 to n do


       a[i]:=random(20);


   for i:=1 to n do


       b[i]:=random(20);


   


   for i:=1 to n do


       write(a[i], '  ');


   writeln('');


   for i:=1 to n do


       write(b[i], '  ');


   


   max_a:=1;


   for i:=2 to n do


       if(a[i]>a[max_a]) then max_a:=i;


   


   max_b:=1;


   for i:=2 to n do


       if(b[i]>b[max_b]) then max_b:=i;


   


   writeln('');


   writeln('Max_a = ',max_a);


   writeln('Max_b = ',max_b);


   


   k:=a[max_a];


   a[max_a]:=b[max_b];


   b[max_b]:=k;


   


   for i:=1 to n do


       write(a[i], '  ');


   writeln('');


   for i:=1 to n do


       write(b[i], '  ');


       


end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота