ayzhan1979
21.05.2023 05:29

Составьте программу на языке программирования Паскаль, в которой требуется выполнить следующие действия: • Пользователь задает с клавиатуры последовательность из n целых чисел (n также определяется пользователем). Найти среднее арифметическое чисел из этой последовательности.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
vikysyakurinna
15.10.2020 14:27

var N,x,S,i:integer;

   SR:real;

begin

 writeln ('кол-во чисел в последовательности N=');

 readln (N);

 S:=0;

 for i:=1 to N do

 begin

   read (x);

   S:=S+x;

 end;

 Sr:=S/N;

 Writeln('Sr=',Sr)

end.

Объяснение:

0,0(0 оценок)
Ответ:
savvakuratov2005
15.10.2020 14:27

--- PascalABC.NET 3.6.2 ---

begin

 var N := ReadInteger();

 var S := ReadSeqInteger(N);

 S.Average.Println;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота