alexsashinav
03.02.2023 15:15

Написать программу на С++, определяющую класс IP адреса (IPv4) IP адрес вводится с клавиатуры в стандартном формате (127.0.0.1).

Программа должна распознать адрес и ответить, к какому классу он относится.

P.S. Не забудьте про адрес возвратной петли.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
arturpushkin202453
13.10.2022 02:19

ответ:

1.

13, вроде бы

1) абдик

2) абджк

3) абвдик

4) абвджк

5) абвжк

6) авжк

7) авджк

8) авдик

9) агек

10) агвжк

11) агвджк

12) агвдик

13) агежк

2.

1.абеил

2.абезл

3.абвеил

4.абвезл

5.абвзл

6.авзл

7.авезл

8.авеил

9.агзл

10.агжзл

11.агжкл

12.адгзл

13.адгжзл

14.адгжкл

15.аджзл

16.аджкл

3.количество путей в город л = сумме путе в города и, з, ж и к (и(3)+з(10)+ж(3)+к(3))=19

4.правильный ответ: 12.

5.в подобных анализ начинают с конечного города (в нашем случае - g). в город g можно попасть из d, f и e ⇒ k(g) = k(d)+k(f)+k(e).

аналогично

k(d) = k(b) + k(f) = 2 + 4 = 6;

k(f) = k(b) + k(c) + k(e) = 2 + 1 + 1 = 4;

k(e) = k(c) = 1;

k(b) = k(a) + k(c) = 1 + 1 = 2;

k(c) = k(a) = 1

k(g) = k(d)+k(f)+k(e) = 6+4+1 = 11

объяснение:

0,0(0 оценок)
Ответ:
arishkakorneva
24.06.2022 22:56

вот мой г**нокод на javascript с одного онлайн-курса, но с использованием while. скину сотку на телефон любому, кто в нем разберется:

function cycle(a, b) {

    while(a ! = b) b = a> b ? [a,a=b][0]-a : b-a

    return a;

}

но поскольку я вижу сверху ключевое слово repeat, полагаю, нужно это сделать в pascal. ради б-га:

var a,b: integer;

begin

    a : = 32;

    b : = 32;

    while not (a = b) do

    begin

        if a > b then begin

            a : = a - b;

        end else

            b : = b - a;

    end;

    writeln(a);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота