shamahuligam007
30.01.2020 08:41

Написать программу на Python:
Алгоритм защиты не позволяет приступить к ремонту Rover без подтверждения прибытия робота на станцию.

Разработай функцию is_rover_arrived(), которая принимает в качестве параметров два кортежа: rover_pos и station_pos с координатами робота и станции соответственно.

Функция должна вернуть True, если Rover прибыл на станцию или False, если этого не случилось.

Входные данные

Два кортежа: rover_pos и station_pos

Выходные данные

Логическое значение

Правила:

Функция должна принимать координаты робота и станции (rover_pos и station_pos) как параметры;
Функция должна возвращать результат с
Функция не должна содержать операций ввода-вывода;
Функция должна называться is_rover_arrived().
Sample Input:

(1, 2)
(-5, 7)
Sample Output:

False
Напишите программу. Тестируется через stdin → stdout

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
shariktop000
24.02.2021 13:20
Если хорошенько задуматься, то получается всего 4 компьютера.
Допустим, дадим этим углам имена 1,2,3,4. 
12      Итак, в каждом углу по одному компьютеру. 
|                |      Назовём эти компьютеры так, тот, что стоит в углу 1
|                |      будет называться К1 (компьютер 1), тот, что стоит в углу 
||      2 будет К2, и тд. (Всего компьютеров: К1,К2,К3,К4).
3              4      Теперь смотрим на рисунок: напротив К1, стоит К3, а напротив К2, стоит К4. То есть, напротив 1 компьютера стоит 3, напротив 3 - 4. То есть, всего 4 компьютера. Даже если эти компьютеры мы повернём лицом к середине комнаты, всего будет 4 компьютера, так как 1 будет смотреть на 4, а 2 на 3. 
ответ: всего 4 компьютера.
  
0,0(0 оценок)
Ответ:
TheNekyTyan
03.02.2020 00:58
Program ZAD00; {} uses crt;
var a,b:array[1..20] of real;
i:integer;
mina,minb,s:real;
Begin
{ заполнение массива А}
for i:=1 to 7 do begin write('введите элементы a[',i,']='); read(a[i]); end;
{ заполнение массива B}
for i:=1 to 9 do begin write('введите элементы b[',i,']='); read(b[i]); end;
{ min в массиве А}
mina:=a[1];
for i:=1 to 7 do begin
a[8]:= 32767 ;
if (a[i]>= a[i+1]) and (a[i+1]<=mina) then mina:=a[i+1]  end;
{ min в массиве B}
minb:=b[1];
for i:=1 to 9 do begin
b[10]:=32767;
if (b[i]>= b[i+1]) and (b[i+1]<=minb) then minb:=b[i+1]  end;
{ сложение minA и minB}
s:=mina+minb;
{ вывод результатов на экран
for i:=1 to 7 do begin write(a[i],' '); writeln; end;
for i:=1 to 9 do begin write(b[i],' '); writeln; end;
writeln('minA=',mina);
writeln('minB=',minb);
writeln('сумма их s=', s);
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота