lenokv
30.01.2020 08:41

Написать программу на Python:

Сигнал передатчика очень слабый, а для полной диагностики и ремонта Rover'у нужно добраться до станции.

Rover-12 может построить маршрут к любой точке в пределах квадрата 10*10 километров от своего местоположения.

Разработай функцию genererate_positon() для выбора случайной точки прибытия в пределах планеты. Для получения координаты точки используй функции из модуля random. В качестве параметра, в функцию передается значение d — максимально допустимое расстояние от Rover до точки прибытия.

Входные данные

Целое число d (-10 ≤ d ≤ 10)

Выходные данные

Кортеж, содержащий координаты точки прибытия (x, y) или None, в случае, когда d ≤ 0.

Правила:

Функция должна принимать расстояние d как параметр;

Функция должна возвращать результат с

Функция не должна содержать операций ввода-вывода;

Функция должна называться genererate_positon().

Напишите программу. Тестируется через stdin → stdout

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ozilpro228
13.06.2022 11:35

Объяснение:

C++Выделить код

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

28

29

30

31

32

33

34

35

#include <iostream>

#include <cstdlib>

#include <ctime>

using namespace std;

 

void main()

{

   setlocale(0, "rus");

   int mas[5][5];

   srand(time(NULL));

   cout << "Первоначальный массив" << endl;

   for (int i = 0; i<5; i++){

       cout << endl;

       for (int j = 0; j<5; j++){

           mas[i][j] = rand() % 10;

           cout << mas[i][j] << " ";

       }

       cout << endl;

}

   

   cout << "Полученный массив" << endl;

   for (int i = 0; i<5; i++){

       int tmp = mas[i][i];

       mas[i][i] = mas[i][5 - i - 1];

       mas[i][5 - i - 1] = tmp;

   }

   cout << endl;

   for (int i = 0; i<5; i++){

       cout << endl;

       for (int j = 0; j<5; j++){

           cout << mas[i][j] << " ";

       }

       cout << endl;

   }

}

0

0,0(0 оценок)
Ответ:
Svasik269
13.06.2022 11:35

Объяснение:

C++Выделить код

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

28

29

30

31

32

33

34

35

#include <iostream>

#include <cstdlib>

#include <ctime>

using namespace std;

 

void main()

{

   setlocale(0, "rus");

   int mas[5][5];

   srand(time(NULL));

   cout << "Первоначальный массив" << endl;

   for (int i = 0; i<5; i++){

       cout << endl;

       for (int j = 0; j<5; j++){

           mas[i][j] = rand() % 10;

           cout << mas[i][j] << " ";

       }

       cout << endl;

}

   

   cout << "Полученный массив" << endl;

   for (int i = 0; i<5; i++){

       int tmp = mas[i][i];

       mas[i][i] = mas[i][5 - i - 1];

       mas[i][5 - i - 1] = tmp;

   }

   cout << endl;

   for (int i = 0; i<5; i++){

       cout << endl;

       for (int j = 0; j<5; j++){

           cout << mas[i][j] << " ";

       }

       cout << endl;

   }

}

0

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота