cobaincurt
07.05.2020 20:37

Задан целочисленный массив А длинной N. Назовем в нем "горкой" такую четверку рядом стоящих элементов с номерами i-2, i-1, i и i+1, для которых выполняется условие A[i-2] < A[i-1] <= A[i] > A[i+1]. Напишите программу,которая определяет количество "горок" в массиве.​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ugifhuf
14.02.2022 07:17

Объяснение:

i=1

while(i<11):

if(i==1):

print(f"Факторіал {i} дорівнює 1 ")

elif(i==2):

print(f"Факторіал {i} дорівнює 2 ")

elif(i==3):

print(f"Факторіал {i} дорівнює 6 ")

elif(i==4):

print(f"Факторіал {i} дорівнює 24 ")

elif(i==5):

print(f"Факторіал {i} дорівнює 120 ")

elif(i==6):

print(f"Факторіал {i} дорівнює 720 ")

elif(i==7):

print(f"Факторіал {i} дорівнює 5040 ")

elif(i==8):

print(f"Факторіал {i} дорівнює 40360")

elif(i==9):

print(f"Факторіал {i} дорівнює 363240")

elif(i==10):

print(f"Факторіал {i} дорівнює 3632400 ")

i=i+1

0,0(0 оценок)
Ответ:
DimaKravshenco
07.02.2023 19:31
// pascalabc.net 3.3, сборка 1579 от 18.11.2017 // внимание! если программа не работает, обновите версию! begin   writeln('*** исходный массив ***');   var a: =matrrandom(2,4,-10,30);   a.println(4); writeln(4*a.colcount*'-');   writeln('п = ',a.elementsbyrow.where(t-> t.between(1,19))           .aggregate(1,(x,y)-> x*y)) end. пример *** исходный массив ***   24  16  22  12     2    5    1    8 п = 15360
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота