dasika1
27.04.2021 18:52

Программа на с++ написать программу, выполняющую следующие действия: • ввод с клавиатуры данных в массив, состоящий из восьми элементов типа marsh; записи должны быть по номерам маршрутов; • вывод па экран информации о маршрутах, которые начинаются или кончаются в пункте, название которого введено с клавиатуры; • если таких маршрутов нет, выдать на дисплей соответствующее сообщение; • добавить обработку исключения на открытие файла

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Foolrelax
06.04.2022 18:38
// PascalABC.Net 3.0, сборка 1064
const
  n = 10;
var
  ms: array[1..n] of string;
  t: string;
  i, j: integer;
  f: Text;
begin
  { Чтение матрицы из файла }
  Assign(f, 'in.txt'); Reset(f);
  for i := 1 to n do Readln(f, ms[i]);
  Close(f);
  { Вывод матрицы на экран }
  Writeln('*** Бинарная матрица ***');
  for i := 1 to n do Writeln(ms[i]);
  { Сортировка обменом (простейшая) }
  for i := 1 to n - 1 do
    for j := 1 to n - 1 do
      if ms[j] > ms[j + 1] then
      begin t := ms[j]; ms[j] := ms[j + 1]; ms[j + 1] := t end;
  { Поиск одинаковых строк }
  Writeln('Совпадающие строки');
  j := 1; t := ms[1];
  for i := 2 to n do
  begin
    if ms[i] = t then Inc(j)
    else begin
      if j > 1 then begin Writeln(t); j := 1 end;
      t := ms[i]
    end
  end;
  if j > 1 then Writeln(t)
end.

Контрольное решение:
*** Бинарная матрица ***
1 1 0 1 0 1 0 1 0 1
0 0 1 0 1 0 1 0 1 0
1 0 1 0 1 0 1 0 1 0
1 1 0 1 0 1 0 1 0 0
0 0 1 0 1 0 1 0 1 1
0 1 0 1 0 1 0 1 0 1
1 1 0 1 0 1 0 1 0 1
0 0 1 0 1 0 1 0 1 0
0 1 0 1 0 1 0 1 0 1
Совпадающие строки
0 0 1 0 1 0 1 0 1 0
0 1 0 1 0 1 0 1 0 1
1 0 1 0 1 0 1 0 1 0
1 1 0 1 0 1 0 1 0 1
0,0(0 оценок)
Ответ:
Катюха1324
12.06.2020 07:57

1. Сайт содержит 5 страниц (главная, 4 страницы без темы (полагаю, это уже Ваша работа), запустится, естественно, только у Вас на компьютере.

2. На каждой странице задан фон, цвет шрифта и размер шрифта. Вы можете менять эти параметры по своему усмотрению. О том, как это сделать, разъясню в комментариях, если будет такая необходимость.

2.1 На каждой странице содержатся гиперссылки (переход на следующую страницу, на предыдущую и возврат на главную страницу) и картинки. Картинки в примере называются "1.png", "2.png" и так далее. Найдете любые картинки по выбранной Вами теме и назовете их, как указано в html-разметке.

3. На главной странице сформирован список, содержащий ссылки на 4 страницы сайта.

Решение поставленной задачи приложено в виде текстового файла, содержащего разметку для 5 html-страниц. Нужно будет создать 5 текстовых файлов с блокнота и назвать их так, как указано в решении (не забыть изменить расширение на .html)

Загрузить text/html

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота