megakolbina
23.08.2021 15:53

Написать программу на языке паскаля авс ***дана матрица. сформировать одномерный массив, элементами которого являются суммы тех строк, которые начинаются с k идущих подряд положительных чисел***

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
dedrina
09.06.2020 22:57

program raf105;

const

 n= 4; //Размер матрицы (кол-во и длинна строк). Можно менять

var

 a:array[1..n,1..n] of integer;

 asum:array[1..n] of integer;

 i,j,k,sum,kolsum: integer;

 x: boolean;

begin

write('Введите число k (не больше ',n,'): ');

readln(k);

for i:=1 to n do

begin

 writeln;

 writeln('Введите ',n,' чис. ',i,' стр.');

 for j:=1 to n do

   readln(a[i,j]);

end;

writeln;

writeln('Суммы элементов тех строк, в которых первые ',k,' элем. положительные');  

for i:=1 to n do

begin

 x:= true;

 sum:= 0;

 for j:=1 to k do

 begin

   if x and (a[i,j] <= 0)

     then x:= false;

 end;

   if x

   then  

   begin

     for j:=1 to n do

       sum+= a[i,j];

     kolsum+= 1;

     asum[kolsum]:= sum;

     writeln(asum[kolsum]);

   end;

end;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота