vitalinaegorova
03.05.2021 11:06

Написать программу на языке OBASIC следующих задач: а)Впишется ли квадрат площадью S в круг радиусом R? Б) Впишется ли квадрат площадью S в круг диаметром D?
В) Впишется ли круг радиусом R квадрат площадью S?
Г) Впишется ли круг площадью S в квадрат со стороной а?
Д)Впишется ли квадрат со стороной а в круг площадью а?
Е) Составить программу вычерчивания российского флага и Флага франции
Решить след задачи:
А) В одной группе 10101(2) студентов,а во второй 10111(2) студентов.Найти насколько во второй группе студентов больше , чем в первой
Задачи решить во всех известных системах счисления
Б) Перевести числа 11 и 99 из 10-й системы в 2-й системе сложить и перемножить
В) сколько единиц в двоичной записи числа 195?
Г) Сколько мегабайт информации содержит Сообщения объемом 2 в 23 степени бит?
Д) Значение выражения 10(16)+10(8)•10(2) в двоичной системе равно:?
Е) вычислите сумму чисел x и y при x= A 7(16) и у=56(8) в двоичной системе счисления
3)Написать программу :
„тест проверки знаний по любому выбранному предмету состоящего из 10 вопросов

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
KolianN
14.02.2022 01:16
From random import shuffle
 
points = 0
points_per_turn = 100
lives = 3
rooms = [("В комнате дракон :(", -1), ("В комнате живая вода :)", 1), ("Комната пуста :|", 0)]
n = len(rooms)
 
while lives > 0:
  print("Жизней: ", lives, ", очков: ", points, sep = "")
  shuffle(rooms)
  print("Выбирайте любую из дверей, введите число от 1 до", n, end=" ")
  choice = int(input()) - 1
  points += points_per_turn
  print(rooms[choice][0])
  lives += rooms[choice][1]
 
print("Коварный дракон лишил вас последней жизни, но тем не менее у вас осталось", points, "очков.")
0,0(0 оценок)
Ответ:
berezniki14
20.02.2022 03:58

Слово «алгоритм» происходит от имени великого Персидского учёного Мухаммеда аль-Хорезми́, жившего в первой половине IX ве́ка (точные годы его жизни неизвестны, но считается, что он родился около 780 года, а умер около 850). «Аль-Хорезми» означает «из Хорезма» (исторической области в нынешнем Узбекистане, центром которой был город Хива).

Около 825 года аль-Хорезми написал сочинение, в котором впервые дал описание придуманной в Индии позиционной десятичной системы счисления. К сожалению, арабский оригинал его книги не сохранился, так что её оригинальное название нам неизвестно. Аль-Хорезми сформулировал правила вычислений в новой системе и, вероятно, впервые использовал цифру 0 для обозначения пропущенной позиции в записи числа (её индийское название арабы перевели как as-sifr или просто sifr, отсюда такие слова, как цифра и шифр). Приблизительно в это же время индийские цифры начали применять и другие арабские учёные. В первой половине XII века книга аль-Хорезми в латинском переводе проникла в Европу. Переводчик, имя которого до нас не дошло, дал ей название «Algoritmi de numero Indorum» («Индийское искусство счёта, сочинение Аль-Хорезми»).

Таким образом, мы видим, что латинизированное имя аль-Хорезми было вынесено в заглавие книги, и сегодня ни у кого нет сомнений, что слово «алгоритм» попало в европейские языки именно благодаря этому сочинению. Однако вопрос о его смысле длительное время вызывал ожесточённые споры. На протяжении многих веков происхождению слова давались самые разные объяснения.

Одни выводили algorism из греческих algiros (больной) и arithmos (число). Из такого объяснения не очень ясно, почему числа именно «больные». Или же лингвистам больными казались люди, имеющие несчастье заниматься вычислениями? Своё объяснение предлагала и знаменитая энциклопедия Брокгауза и Ефрона (1890 год). В ней алгорифм (кстати, до революции использовалось написание алгориѳм, через «фиту») производится «от арабского слова Аль-Горетм, т. е. корень». Разумеется, эти объяснения вряд ли можно счесть убедительными.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота