Инка1999
07.09.2022 02:50

Задача на паскале. Батарея состоит из прямоугольных обогревательных секций. Все секции имеют одинаковый размер и одинаковую мощность. Однако, ремонт батареи, в случае выхода из строя одной из секции - очень трудоемкая задача, поэтому на складе запчастей, батарейные блоки бывают L разных видов: шириной в 1 секцию, в 2 секции, ...,в L секций. Такой блок из нескольких секций нельзя разрезать на части, то есть одним блоком можно заменить не более любых L подряд идущих секций. При этом можно менять не только неисправные секции, но и хорошие(стоимость блоков учитывать не будем - работа все-равно выходит дороже). Определите, какое наименьшее число блоков необходимо взять мастеру, чтобы починить всю батарею.

Формат ввода
Первая строка входных данных содержит целое число L(L > 0) - максимальный размер батарейного блока. Во второй строке входных данных записано целое число N(N > 0) - количество секций в заборе. Следующие N строк содержат по одному числу, равному 0 или 1. Число 1 обозначает, что соответствующая секция в батарее нуждается в замене, число 0 - что секция может быть сохранена.

Формат вывода
Программа должна вывести одно целое число - сумму введенных чисел N и M.
Пример
Ввод Вывод
3 2
8
0
0
1
0
1
0
1
0

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
monyachina1081p08tm7
17.08.2020 02:07

1.

program asd;
uses crt;
var
a: array[1..10] of integer;
i:integer;
sum:integer;
begin
writeln('Введите 10 цифр по очереди');
for i:=1 to 10 do
begin
readln(a[i]);
if (a[i]>7) then begin a[i]:=7; sum:=sum+1; end;
end;

writeln(' ',sum);

end.

 

2. смысл задания? 10/2=5 или индексами ты имела ввиду значениями? 

3.
program asd;
uses crt;
var
a: array[1..10] of integer;
i:integer;
naib:integer;
begin
writeln('Введите 10 цифр по очереди');
for i:=1 to 10 do
begin
readln(a[i]);
if (a[i]>naib) then naib:=a[i];
end;

writeln(' ',naib);

end.

0,0(0 оценок)
Ответ:
Kira25112016
17.08.2020 02:07

Семейство маковых - Papaueraceae


Однолетнее травянистое растение до 100 - 120см высоты с крупными одиночными цветками, лепестки белого цвета с фиолетовым глазком. Стебель прямой. Листья крупные, яйцевидные. Плод - шаровидная или овально - продолговатая коробочка с семенами. Цветет в июне - августе, плоды созревают в августе - сентябре.


Размножаются семенами.

 


Используют в медицине зрелые(сухие) коробочки со стеблем до 40 см, собираемые в период созревания семян. Из мака приготавливают обезболивающие препараты и антиспазматическое средство.

 


Мак выращивается в СССР в Казахстане, Киргизии, на Украине и в Поволжье.

 


Маки представлены однолетними, двулетними и многолетними растениями. Зимостойкие, светолюбивые, они предпочитают легкие богатые гумусом почвы, содержащие известь. Цветут 2–3 дня. Однолетние маки, срезанные с чуть треснувшими бутонами и сразу опущенные в воду, цветут дольше, чем в грунте. Маки можно пересаживать; размножают семенами.

Наиболее распростаренные виды маков: мак полевой мак голубой мак голостебельный (сибирский) мак восточный и прицветковый


Мак полевой (самосейка) – растение однолетнее. За блестящие лепестки его называют также “шелковым маком”. Цветет с конца мая до осени.

 

Семена очень мелкие, поэтому их лучше предварительно намочить и смешать с песком в соотношении 1:10. Сажать гнездовым всходы прореживать. Чтобы продлить сроки цветения, можно сеять несколько раз в течение сезона с интервалами 20–30 дней.

 

Мак голубой – двулетнее растение, можно использовать как однолетник. Семена высевают в грунт весной, всходы прореживают.

 

 

Мак голостебельный, или сибирский – многолетнее растение, используется и как двулетник. Цветет с мая по сентябрь. Семена высаживают весной или в августе. При подзимнем посеве зацветает в мае следующего года.

 

 

Маки восточный и прицветковый – многолетние неприхотливые морозостойкие растения. Хорошо растут на открытом месте, легко переносят небольшое затемнение, но при переувлажнении могут загнивать корни.

 

 

Оба вида размножаются семенами, корневыми и зелеными черенками. Посев производят рано весной в парники или теплицы, пикируют в фазе 1–2-х настоящих листьев и сразу высаживают на постоянное место. На черенки используют боковые слабые побеги, которые осторожно срезают и высаживают на затененные, влажные гряды. Лучшее время пересадки – середина лета или 2-я половина августа.

 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота