dimao2003
13.08.2021 22:18

C++ или Pascal или C# Написать программу, которая запрашивает вещественное число a и, пользуясь только операцией умножения, вычисляет a28 за шесть операций

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Kracylia
15.10.2020 13:41

   class Program

   {

       static void Main(string[] args)

       {

           Console.WriteLine("[Введите число]\n");

           int a = Int32.Parse(Console.ReadLine());

           int a2 = a * a;

           int a4 = a2 * a2;

           int a8 = a4 * a4;

           int a16 = a8 * a8;

           int result = a16 * a8 * a4;

           Console.WriteLine("\nИсходное число: " + a + " \nЧисло в 2-й степени:" + a4 + " \nЧисло в 8-й степени: " + a8 + " \nЧисло в 16-й степени: " + a16 + " \nЧисло в 28-й степени: " + result + "");

       }

   }  

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота