kurzaevaelenka
04.01.2020 14:56

Текст программы, написанный на языке программирования (MATLAB, OCTAVE или любой бесплатный аналог MATLAB). В текст программы следует добавить комментарии, поясняющие, что делает та или иная команда.
Результат работы программы (то, что выводится на экран в результате работы программы). Это также следует набрать шрифтом Courier New.
Небольшое заключение, в котором должно указываться, какие результаты вы получили в данном задании. Желательно сделать небольшой анализ полученных результатов, подтверждающий их правильность.
1)Дана матрица - вводится из файла .txt Х(m,n). Числа m, n и элементы матрицы вводятся пользователем. Найти номера строк этой матрицы, все элементы которой различны. Определение номера строки матрицы, все элементы которой различны, через функцию.

2)Найти сумму элементов, стоящих на побочной диагонали массива размером МхN, элементы которого вводятся из файла. Вычисление суммы через функцию.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
даша3609
05.09.2022 07:11
Т.к. язык программирования не указан, сделаю на свой вкус, т.е. C++. При копировании кода из IDE на сайт автоматически удаляется перенос строки. Будет прикреплен скриншот того, как должен выглядеть код

#include <stdlib.h>#include <stdio.h>#include <locale>
void main(){ setlocale(LC_ALL, "RUSSIAN"); int i, n, an; an = 0; printf("\n Введите n ->"); scanf_s("%d", &n); for (i = 1; i <= n; i++) an = an+i; printf("\n Сумма первых n натуральных чисел равна: %d", an); an = 0; for (i = 1; i <= n; i++) an = an + i*i; printf("\n Сумма квадратов первых n натуральных чисел равна: %d", an); an = 0; for (i = 1; i <= n; i++) if (i % 2 == 0)an = an + i; printf("\n Сумма всех четных чисел в диапозоне от 1 до n: %d", an); an = 0; for (i = 10; i <= 99; i++) an = an + i; printf("\n Сумма всех двухзначных чисел равна: %d \n", an); system("pause");}

Напишите программу,которая вычисляет сумму : а)первых n натуральных чисел; б)квадратов первых n нату
0,0(0 оценок)
Ответ:
Salvatation1230
05.09.2022 07:11
Текстовый алгоритм

Есть снег для лепки снеговика?

Нет - выполнение невозможно.

Есть, то: 

слепить три разновеликих шара;

установить шары друг на друга в порядке убывания;

сверху установить ведро дном вверх;

в центр верхнего шара установить морковь, над ней два уголька-глаза;

по бокам среднего шара вставить веточки-ручки.

Фигуры блок-схемы

Последовательность фигур может меняться в зависимости от требуемых условий и действий:

овал - обозначает начало блок-схемы и содержит само слово "начало" - ограничивающий символ;

параллелограмм - символ ввода-вывода данных;

прямоугольник обозначает действие - символ выполнения операции;

ромб  - фигура, содержащая условие, после которой происходит ветвление алгоритма - символ принятия решения;

круг используется при разрыве записи блок-схемы;

прямоугольник с удвоенными боковыми сторонами обозначает применение подпрограммы - символ повторяемости процесса;

заканчивается запись блок-схемы всегда овалом, который содержит слово "конец".

Порядок выполнения действий указывается линиями.

Блок-схема создания снеговика

Алгоритм создан при идеальных условиях:

если снег есть, то возможно скатать шары для снеговика;

в наличии есть ведро-шапка, морковь-нос, угольки и подходящие веточки;

никто не разрушает созданные фигуры. 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота