baekksas
19.06.2022 02:25

Написать программу. Вычислить сумму наибольших элементов каждого столбца матрицы A(I*J), записанный в текстовый файл. Сформировать из них вектор С, и дописать его в файл. C++ в Visual Studio.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
КсенияБыкК
03.11.2022 12:48

Объяснение:

#include <iostream>

#include<vector>

#include <algorithm>

using namespace std;

int main() {

ios::sync_with_stdio(false);

int N, A, B;

cin >> N;

vector < vector <int>> IO;

int lastDay = 0;

for (int i = 0; i <  N; i++) {

 cin >> A >> B;

 IO.push_back(vector<int>());

 IO[i].push_back(A);

 IO[i].push_back(B);

 IO[i].push_back(i);

}

sort(IO.begin(), IO.end());

for (int i = 0; i < N; i++)

{

 if (lastDay >= IO[i][1]) {

  IO[i][0] = -1;

  IO[i][1] = -1;

 }

 else {

  if (lastDay < IO[i][0]) {

   lastDay = IO[i][1];

  }

  else if (lastDay >= IO[i][0]) {

   IO[i][0] = lastDay+1;

   lastDay = IO[i][1];

  }

 }

}

for (int i = 0; i < N; i++) {

 for (int j = 0; j < N; j++) {

  if (IO[j][2] == i) {

   cout << IO[j][0] << " " << IO[j][1] << endl;

   break;

  }

 }

}

return 0;

}

0,0(0 оценок)
Ответ:
милкаshow
01.08.2021 04:26

Рассмотрим решение на языке Python

Объяснение:

Первый

Отсортируем имеющийся список как показано.

Получим кортеж, где есть два значения: key и value.

Первое число - собственно, элемент. Второе число - количество раз.

Второй

Создадим словарь и будем считать количество элементов.

Выведем второй элемент кортежа максимального значения

Третий

Создадим словарь, множество, список ключей.

Как и во втором , пройдемся по элементам и будем увеличивать счетчик на 1.

Выведем с метода format, чтобы было красиво.

Четвертый

Самый простой, и тем не менее, правильно работающий. Используем библиотеку collections, откуда возьмем тип данных Counter - словарный тип, используемый для подсчета объектов.


Дан массив из 20 случайных чисел от 1 до 10. Вывести в консоль самое часто встречающееся число или с
Дан массив из 20 случайных чисел от 1 до 10. Вывести в консоль самое часто встречающееся число или с
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота