Kvasya07
03.04.2022 09:22

Написать программу на языке программирования Pascal, вычисляющую значение функции. Значения А, В, С, х вводятся с клавиатуры.


Написать программу на языке программирования Pascal, вычисляющую значение функции. Знач

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
krasnov595egr
02.02.2021 02:05
Var f:file of integer;   
 a,i,k,n:integer;
begin
randomize;
assign(f,'file');
rewrite(f);
repeat
write('Четное количество элементов: ');
readln(n);
until(n>1) and (n mod 2=0);
for i:=1 to n do
 begin 
 a:=random(100); 
 write(f,a); 
end;
writeln('Содержание исходного файла:');
reset(f);
while not eof(f) do
 begin 
 read(f,a); 
write(a,' ');
 end;
close(f);
writeln;
reset(f);
seek(f,filesize(f)div 2);
truncate(f);
writeln('Содержание измененного файла:');
reset(f);
while not eof(f) do
 begin
  read(f,a); 
 write(a,' '); 
end;
close(f);
readln
end.
0,0(0 оценок)
Ответ:
yulyashka01
02.02.2023 13:08
1.Какое устройство компьютера моделирует мышление человека?
-Процессор

2.Действия над исходной информацией (фактами) в соответствии с некоторыми правилами - это
-обработка информации

3.Из предложенных сообщений выбрать правило
-при умножении простых дробей их числители и знаменатели перемножаются

4.Для кого, вероятнее всего, будет информативным следующее сообщение: «Программа - это алгоритм, записанный на языке программирования»?
-начинающий программист

5.Где хранится выполняемая в данный момент программа и обрабатываемые ею данные?
-в оперативной памяти

6.Какое устройство компьютера осуществляет процесс дискретизации звука?
-звуковая карта

7.Информативность сообщения, принимаемого человеком, определяется
-наличием новых знаний и понятностью

8.Вместо многоточий вставьте соответствующие понятия: «Каталог содержит информацию о ..., хранящихся в...»
A) файлах, внешней памяти

9.Указать команду(ы), при выполнении которой(ых) выделенный фрагмент попадает в буфер обмена
В) вырезать и копировать

10.Какие из перечисленных действий относятся к форматированию текста?
-установка режима выравнивания

11.В прикладное программное обеспечение входят:
В) текстовые редакторы

12.Операционная система - это
-комплекс программ, организующих управление работой компьютера и его взаимодействие с пользователем

13.Предложены команды
5Сделать диск А текущим.
2Создать каталог TOWN
3Создать каталог STREET
1Создать файл Home.txt
4Войти в созданный каталог
Расположить пронумерованные команды так, чтобы был получен алгоритм, с которого на пустой дискете создается файл с полным именем A:\TOWN\STREET\Home.txt
Б) 5,2,3,1

14.Для хранения текста требуется 84000 бита. Сколько страниц займет этот текст, если на странице размещается 30 строк по 70 символов в строке? Для кодирования текста используется таблица кодировки, состоящая из 256 символов.
84000/(log(256)/log(2))/30/70 = 5

15.Книга состоит из 64 страниц. На каждой странице 256 символов. Какой объем информации содержится в книге, если используется алфавит из 32 символов?
А) 81920 байтов Б) 40 Кбайт В)10 Кбайт Г) 16 Кбайт Д) 64 Кбайт
64*256*(log(32)/log(2)) /8/1024 = 10

16.Сколько символов содержит сообщение, записанное с символьного алфавита, если его объем составил 1/16 часть Мегабайта?
(1/16)*1024*1024*8/(log(16)/log(2)) = 131072

17.Сколько памяти занимает графическое изображение, если его размер 40x60 и для кодирования цвета пикселя используется двоичный код из 32-х битов.
А) 2400 байтов  Б) 2100 байтов  В) 960 байтов Г) 9600 байтов    Д) 12000 байтов
40*60*32/8 = 9600

18.Текст занимает 0,25 Кбайт памяти. Сколько символов содержит этот текст, если используется таблица кодировки, состоящая из 256 символов?
0.25*1024*8/(log(256)/log(2)) = 256

19.Сколько битов информации содержится в сообщении объемом четверть Килобайта?
1/4*1024*8 = 2048
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота