samoilenkoludmi
29.11.2020 17:42

Словесное описание программы
{
string name;
double cena;
string data;
public:
Tovar(string name, double cena, string data)
{
this->name = name;
this->cena = cena;
this->data = data;
}
string Getname()
{
return name;
}
string Getdata()
{
return data;
}
};
string Function(class Tovar **, string, int);
int main() {
class Tovar t1("Kartofel", 2000, "21.09.19");
class Tovar t2("Zefir", 1400, "18.12.19");
class Tovar t3("Caxar", 300, "15.07.18");
class Tovar t4("Xleb", 200, "22.12.19");
Tovar * tovar[4] = {&t1, &t2, &t3, &t4};
string st = "Caxar";
int i;
cout << "tovat: " << st << endl;
for (int i = 0; i < 4; i++)
if (tovar[i]->Getname() == st) cout< return 0;
}
string Function(class Tovar **tovar, string st, int i) {
return tovar[i]->Getdata();
}

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Аропахора
26.07.2021 13:20

ответ все этапы технологии решения задачи на компьютере на примере конкретной задачи.

1. Постановка задачи. Дано N кубиков, на которых написаны разные буквы. Сколько различных N -буквенных слов можно составить из этих кубиков (слова не обязательно должны иметь смысл)?

Искомую целочисленную величину обозначим буквой F. Тогда постановка задачи выглядит так:

Дано: N.

Найти: F.

2. Математическая формализация. Получим расчетную формулу. Сначала рассмотрим несколько конкретных примеров. Имеются два кубика с буквами «И» и «К». Ясно, что из них можно составить два слова:

ИК КИ.

Добавим к ним третью букву, «С». Теперь число разных слов будет в три раза больше предыдущего, т. е. равно 6:

ИКС КИС ИСК КСИ СКИ СИК.

Если добавить четвертую букву, например «А», то число слов возрастет в четыре раза и станет равным 24:

Объяснение:

0,0(0 оценок)
Ответ:
ghost133
26.07.2021 13:20

Комбинаторные алгоритмы предназначены для выполнения вычис-

лений на различного рода объектах, возникающих в прикладных ком-

бинаторных задачах и при исследовании дискретных математических

структур. Необходимость разработки эффективных, быстрых комби-

наторных алгоритмов уже давно не вызывает сомнений. На практике

нужны не алгоритмы, а хорошие алгоритмы в широком смыс-

ле. Одним из основных критериев качества алгоритма является время,

необходимое для его выполнения.

Разработке и анализу вычислительной сложности комбинаторных

алгоритмов над классическими комбинаторными объектами посвящено

настоящее учебное пособие. Наряду с теоретическими знаниями даётся

описание таких важнейших алгоритмов, приводится их строгое обосно-

вание и детально изучается асимптотическая сложность рассматривае-

мых алгоритмов. Мы познакомим читателя с широким кругом понятий

и сведений из дискретной математики, необходимых практикующему

программисту. Пополним запас примеров нетривиальных алгоритмов

над объектами дискретной математики существенно обо-

гатить навыки самостоятельного конструирования алгоритмов и сфор-

мировать мышление, позволяющее использовать методы дискретного

анализа при разработке эффективных алгоритмов для решения прак-

тических задач и оценке их сложности.

Для понимания материала учебного пособия требуется знание ос-

новных понятий и фактов из дискретной математики и математической

логики. Читатель должен обладать минимальным опытом программи-

рования, каждый изучаемый алгоритм снабжен понятным псевдокодом,

позволяющим реализовать рассматриваемый алгоритм на доступном

языке программирования. При изучении отдельных тем используются

основы математического анализа и теории вероятностей.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота