Ангелиныч1
24.02.2021 21:01

PYTHON Мне нужно объяснение задачи без кода)

Правительство Флатландии решило провести реформу денежной системы. Цель реформы – радикально уменьшить число банкнот в обращении, в результате их должно остаться ровно две. Таким образом, после реформы во Флатландии будут циркулировать банкноты достоинством a тугриков и b тугриков, где a и b поручено выбрать министерству финансов.

Одна из проблем заключается в том, что президент Флатландии ненавидит число x. Поэтому министр финансов решил, что выберет такие a и b, что нельзя будет заплатить ровно x тугриков без сдачи. С другой стороны, для любой суммы большей x должна быть возможность заплатить ее без сдачи.

Итак, вам поручено выбрать соответствующие a и b.

Входные данные

Входной файл INPUT.TXT содержит натуральное число x, не превосходящее 1012.

Выходные данные

В выходной файл OUTPUT.TXT выведите два целых числа a и b такие, что сумму в x тугриков нельзя заплатить банкнотами в a и b тугриков без сдачи, а любую большую сумму – можно. Если решения не существует, выведите в выходной файл два нуля.

Примеры

№ INPUT.TXT OUTPUT.TXT

1. 3 / 2 5

2. 4 / 0 0

3. 5 / 3 4

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
mashenkalarchenko
08.04.2022 13:48
№1

var sum, i: integer;
begin
sum := 0;
for i := 1 to 100 do
sum := sum + i;
writeln('Сумма всех чисел от 1 до 100: ', sum);
end.

№2

var p, i: integer;
begin
p := 1;
for i := 1 to 10 do p := p * i;
writeln('Произведение всех чисел от 1 до 10: ', p);
end.

№3

У вас не дано никаких условий. Вот задача для условия: "Членов прогрессии - 100, шаг - 3"

var A, i, k, max: integer;
begin
i := 3;
max := 100;
for k := 1 to max do begin
A := A + i;write( A, ' ');
end;
end.

№4

var sum, x: real;
a: array[1..10] of real;
i: integer;
begin
sum := 0;
for i := 1 to 10 do begin
write('Введите ', i, ' число: ');
readln(a[i]);
sum := sum + a[i];
end;

writeln('Сумма введенных чисел: ', sum);
end.
0,0(0 оценок)
Ответ:
марлен223
02.08.2022 13:50
Program qq; 
var x, y, z, c, a, b: real; 
begin 
writeln('Введите стоимость билета бизнесс-класса:'); 
readln(x);   
if x > 0 then 
begin   
y:= x / 2;   
writeln('Введите количество оставшихся билетов бизнесс-класса, затем введите количество оставшихся билетов эконом-класса');   
readln(a, b);       
if (a >=0) and (b >= 0) then     
begin       
c:= a*x + y*b;       
z:= (120*y + 40*x) - c ;       
writeln('Доход авиакомпании:', z);     
end     
else     
writeln('Решение невозможно'); 
end; 
end.

Вот так всё работает.
1. Не там поставили end;
2. лишнее else writeln('Решение невозможно');
3. У меня ругался паскаль на то что в условия при and не взяты в круглые скобки. if (a >=0) and (b >= 0) then 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота