НаsтяПоможет777
16.10.2022 21:45

Язык С (функции)

Написать программу, которая выдает значение функции Y = 6x2 + arctg(x), угол вводится в градусах. Перевод в радианы и поиск значения Y выполнить в функции, куда x передается в виде параметра.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
рай34
13.10.2022 15:10

Снизу

Объяснение:

x % 2 == 0 это 1.

Если остаток X от деления на 2 равняется нулю, тогда условие выполняется.

x % 2 != 0 это 2.

Думаю понятно из первого.

x % 10 == y % 10 это 3.

Если остаток от деления X на 10 равняется остатку Y на 10 условие выполняется. думаю понятно почему остаток отделения на 10 это последняя цифра.

x % 10 == 0 or y % 10 == 0 это 4.

Это как два условия в одном, если x делится на 10 или y делится на 10 то условие выполняется.

X * Y % 2 == 0 это 6.

Из 4 класса известно если умножить четное на нечетное получится всегда четное.

(X + 1) * (Y + 1) % 2 == 0 это должно быть 7 т.к если оба числа четные то Ч + 1 = НЧ, а НЧ * НЧ = НЧ и условие не будет выполняться, а если есть хотя бы одно нечетное, то НЧ + 1 = Ч. И условие выполнится.

(X + 1) * (Y + 1) % 2 != 0 это 5.

Если оба числа четные - то они оба станут нечетными и произведение не будет делится на 2, а в других случаях будет одно четное что можно легко перебрать.

Фух, вроде всё.

0,0(0 оценок)
Ответ:
ufjcigi
13.04.2021 00:37

Первая программа

var a,b,c: integer;

min, max, s: integer;

begin

writeln('Введите числа');

readln(a,b,c);

if (a>b) then max:=a else max:=b;

if (c>max) then max:=c;

if (a<b)then min:=a else min:=b;

if (c<min)then min:=c;

s:=max+min;

writeln('Сумма максимального и минимального числа =', s);

end.

Вторая программа

Она состоит из процедуры и выводит на экран начальное уравнение, корни уравнения и дискриминант.

program sqrturavnenie;

uses crt;

Var a, b, c:Real;

procedure sq(a, b, c:Real);

Var d, x1, x2:Real;

Begin

d:=b*b-4*a*c;

Writeln ('d= ', d) ;

If d>=0 then begin

x1:=(-b+sqrt(d)) /(2*a);

x2:=(-b-sqrt(d))/(2*a);

If x1=x2 then

Writeln ('x1= ', x1:6:2)

else

Writeln ('x1=', x1:6:2, 'x2= ', x2:6:2)

End

Else

Writeln ('Корней нет!');

End;

begin

Clrscr ;

Writeln ('a= ');

Readln (a);

Writeln ('b= ');

Readln (b);

Writeln ('c=') ;

Readln (c);

Writeln (a:6:2,'x*x+ ', b:6:2, 'x+ ', c:6:2);

sq(a, b, c);

Readln

end.

С комментариями будет трудно

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота