Dasha555559
19.11.2020 03:13

Интерпретатор языка Питон выполнил следующее присваивание:

N = a % 3 + b / c ** d ** e - f // 10
# 1 2 3 4 5 6 7
Арифметические операции пронумерованы слева направо. Во второй строке, начинающейся с комментария — символа «#», под каждой арифметической операцией указан ее номер. Определите последовательность действий — порядок, в котором будут выполнены данные операции. В ответе укажите только номера операций, слитно, без пробелов и запятых.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
1553VinyaPyhtya
20.01.2021 00:54

function summa(n:integer):integer;

var a,s:integer;

begin

a:=abs(n);

s:=0;

while a>0 do

begin

 s:=s+a mod 10;

 a:=a div 10;

end;

summa:=s

end;

const n=10;

var A:array [1..n] of integer;

   j,i,k:integer;

begin

writeln('Исходный массив: ');

for i:=1 to n do

begin

 A[i]:=random(15)+1;

 write(A[i]:4);

end;

for i:=1 to n-1 do

begin

 for j:=1 to n-1 do

 if summa(A[j])<summa(A[j+1]) then

  begin

   k:=A[j];

   A[j]:=A[j+1];

   A[j+1]:=k

  end;

end;

writeln;

writeln('Отсортированный массив: ');

for i:=1 to n do

write(A[i]:4);

readln

end.

0,0(0 оценок)
Ответ:
enikeevanellya
20.01.2021 00:54

function summa(n:integer):integer;

var a,s:integer;

begin

a:=abs(n);

s:=0;

while a>0 do

begin

 s:=s+a mod 10;

 a:=a div 10;

end;

summa:=s

end;

const n=10;

var A:array [1..n] of integer;

   j,i,k:integer;

begin

writeln('Исходный массив: ');

for i:=1 to n do

begin

 A[i]:=random(15)+1;

 write(A[i]:4);

end;

for i:=1 to n-1 do

begin

 for j:=1 to n-1 do

 if summa(A[j])<summa(A[j+1]) then

  begin

   k:=A[j];

   A[j]:=A[j+1];

   A[j+1]:=k

  end;

end;

writeln;

writeln('Отсортированный массив: ');

for i:=1 to n do

write(A[i]:4);

readln

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота