Папинадочка111
20.10.2022 09:08

Вставка числа
Требуется вставить в данный массив на данное место данный элемент, сдвинув остальные элементы вправо.

Входные данные

В первой строке вводится одно натуральное число, не превосходящее 1000 — размер массива. Во второй строке задаются N чисел — элементы массива (целые числа, не превосходящие по модулю 1000). В третьей строке вводится число, которое необходимо вставить, и номер места, на которое его нужно вставить.

Выходные данные

Вывести получившийся массив.

Примеры
Ввод
Вывод
5
1 2 3 4 5
2 3
1 2 2 3 4 5

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Ilonka2734
28.04.2022 22:39
// PascalABC.NET 3.3, сборка 1625 от 17.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln('*** Исходный массив ***');
  var v:=MatrRandom(7,7,-15,15);
  v.Println(4); Writeln(4*v.ColCount*'-');
  var pr3:=v.Row(2).Aggregate(1,(x,y)->x*y);
  Writeln('Произведение элементов 3-й строки равно ',pr3);
  Writeln('Количество элементов, больших этого произведения, равно ',
      v.ElementsByRow.Where(t->t>pr3).Count);
  Writeln('Максимум в 3-м столбце равен ',v.Col(2).Max)
end.

Пример
*** Исходный массив ***
  -4 -12 -15  -2  13   3 -15
  -7  -1 -15   2  -2   4  -6
  14   5   5  15  -4   3   0
  13  15   9  14  11  -9  11
   1  14  14   1  -4  -1  -7
  15 -10 -13  -3  -8 -12  11
   0 -13  -8   4   6   1 -11

Произведение элементов 3-й строки равно 0
Количество элементов, больших этого произведения, равно 24
Максимум в 3-м столбце равен 14
0,0(0 оценок)
Ответ:
haaahahaha12345
28.04.2022 22:39
// PascalABC.NET 3.3, сборка 1576 от 16.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
var V:=MatrRandom(7,7,-15,15);v.Println;
var com:= V.Row(2).Aggregate(BigInteger(1),(x,y)->(x*y));
Writeln('Произведение эл-в 3ей строки = ', com);
var cnt := 0;
Foreach var x in V.Row(2) do
  if x > com then inc(cnt);
Writeln('Количество элементов, больших чем это произведение = ', cnt);
Writeln('Максимальный элемент 3го столбца = ', V.Col(2).Max);
end.

Пример:
    2  -4 -15  10  -1   2   6
  15  -8  11   5  14  10  15
   0  15 -10  13  -8 -13  14
  14   6  13 -10   9   6 -12
 -14   1   8  -9   1 -12  12
  15   9  10  -7 -14   6  -3
   9   9  -1 -14   1   1   3
Произведение эл-в 3ей строки  = 0
Количество элементов, больших чем это произведение = 3
Максимальный элемент 3го столбца = 13

Правил
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота