millergil
28.01.2023 16:57

Составить программу для нахождения произведения модулей отрицательных значений функции

у= sin2x-0.5, где х∈[0,10], Δx=0,1 и суммы ее положительных значений.

с var, writeln и тд. чем проще, тем лучше

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
777stepan777
13.10.2022 15:01

var

 n, Num, i, j, t: integer;  

 Count: array[1..12] of integer;  

 Names: array[1..12] of integer;

begin

 for i := 1 to 12 do  

 begin

   Count[i] := 0;  

   Names[i] := i;  

 end;  

 ReadLn(N); { Считываем количество запросов}  

 for i := 1 to N do  

 begin

   ReadLn(t); {считали очередной запрос}  

   Count[t] := Count[t] + 1;  

 end;  

 {Сортируем массивы Names и Count в порядке убывания значений массива Count}  

 for i := 12 downto 2 do  

   for j := 2 to i do  

     if Count[j - 1] < Count[j] then  

     begin

       t := Count[j];

       Count[j] := Count[j - 1];

       Count[j - 1] := t;

       t := Names[j];

       Names[j] := Names[j - 1];

       Names[j - 1] := t;

     end;  

 for i := 12 downto 1 do  

   if Count[i] > 0 then  

     WriteLn(Names[i], ' ', Count[i]);  

end.

Объяснение:

0,0(0 оценок)
Ответ:
rewington1
26.10.2022 17:40

c++

Объяснение:

#include <iostream>

using namespace std;

const int m = 6;

const int n = 4;

int main() {

   int a[m][n];

   /*Ввод массива*/

   for(int i = 0;i < m;i++) {

       for(int j = 0;j < n;j++) {

           cout << "A[" << i << "][" << j << "] = ";

           cin >> a[i][j];

       }

   }

   

   int sum = 0;

   int mult = 1;

   

   for(int i = 0;i < m;i++) {

       for(int j = 0;j < n;j++) {

           sum += a[i][j];

           mult *= a[i][j];

       }

   }

   

   cout << "Sum = " << sum << endl << "Mult = " << mult;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота