лошадь20
01.05.2023 01:09

Напишите программу, которая получает с клавиатуры два натуральных числа и находит их НОД с алгоритма Евклида. Программа должна подсчитать количество шагов цикла. С

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
tearprincess200225
15.10.2020 11:11

#include <iostream>

using namespace std;

int NOD(int a, int b) {

   

   int iter = 0;

   if (a < b) {

       swap(a, b);

   }

   while (a % b != 0) {

       a = a % b;

       swap(a, b);

       iter++;

   }

   cout<<"NOD: "<< b << " Iteration: "<< iter;

}

int main()

{

   int a,b;

   cin>>a>>b;

   NOD(a,b);

   return 0;

}


Напишите программу, которая получает с клавиатуры два натуральных числа и находит их НОД с алгоритма
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота