angelinamikhay
03.05.2020 21:10

Составить программу вычисления функции на паскале ABC.NET на заданных промежутках и с заданным шагом h.

используя var, const, writeln и тд, всё что нужно. чтобы было понятно


Составить программу вычисления функции на паскале ABC.NET на заданных промежутках и с заданным шаго

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
dnmsmd
02.04.2023 14:17
// PascalABC.NET 3.2, сборка 1379 от 21.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=''+
         '';
  foreach var c in s do Writeln(c,' ',ORDANSI(c))
end.

Результат
А 192
Б 193
В 194
Г 195
Д 196
Е 197
Ё 168
Ж 198
З 199
И 200
Й 201
К 202
Л 203
М 204
Н 205
О 206
П 207
Р 208
С 209
Т 210
У 211
Ф 212
Х 213
Ц 214
Ч 215
Ш 216
Щ 217
Ъ 218
Ы 219
Ь 220
Э 221
Ю 222
Я 223
а 224
б 225
в 226
г 227
д 228
е 229
ё 184
ж 230
з 231
и 232
й 233
к 234
л 235
м 236
н 237
о 238
п 239
р 240
с 241
т 242
у 243
ф 244
х 245
ц 246
ч 247
ш 248
щ 249
ъ 250
ы 251
ь 252
э 253
ю 254
я 255
0,0(0 оценок)
Ответ:
ПростоПапаЮра
02.04.2023 14:17
//прога на Pascal`е
{не работает на  PascalABC.Net, т.к. оный использует 2-байтную кодировку Unicode, а не 1-байтную кодировку ASCII, как более ранние версии Pascal`ей}
const
n = 32*2;
var
ch: array [1..n] of byte;
i, num: byte;
begin
num:=192;
for i:=1 to n do
begin
ch[i]:=num;
inc (num);
end;

writeln ('Символ   |   Код ASCII');
writeln ('');
for i:=1 to n do writeln ('   ', chr(ch[i]), '     |    ', ch[i]);end.

{версия для PascalABC.Net}
//прога на Pascal`е
const
n = 32*2;
var
ch: array [1..n] of byte;
i, num: byte;
begin
num:=192;
for i:=1 to n do begin
ch[i]:=num;
inc (num);
end;

writeln ('Символ   |   Код ASCII');
writeln ('');
for i:=1 to n do writeln ('   ', chr(ch[i]+848), '     |    ', ch[i]);

end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота