Ирина132435
19.02.2023 12:45

написать программу на с++
Найти максимум среди сумм элементов диагоналей, параллельных главной диагонали матрицы

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
rustie
29.05.2020 23:10

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

max = INT_MIN;

for(t = 1; t < Len; ++t)

{

sum1 = 0;

i1 = t;

j1 = 0;

sum2 = 0;

i2 = 0;

j2 = t;

while(i1 < Len && j2 < Len)

{

sum1 += matrix[i1][j1];

sum2 += matrix[i2][j2];

++i1;

++j1;

++i2;

++j2;

}

maxsum = sum1 > sum2 ? sum1 : sum2;

max = maxsum > max ? maxsum : max;

}

cout<<max<<endl;

вот так получица)

1

a-Nutka

3 / 3 / 0

Регистрация: 20.01.2009

Сообщений: 6

26.04.2009, 1

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота